summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/replicatorg/replicatorg-37-r2.ebuild72
-rw-r--r--media-gfx/replicatorg/replicatorg-40-r1.ebuild72
2 files changed, 80 insertions, 64 deletions
diff --git a/media-gfx/replicatorg/replicatorg-37-r2.ebuild b/media-gfx/replicatorg/replicatorg-37-r2.ebuild
index fbb7b8981eab..d2ec0905f939 100644
--- a/media-gfx/replicatorg/replicatorg-37-r2.ebuild
+++ b/media-gfx/replicatorg/replicatorg-37-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit eutils versionator user
+inherit versionator user
MY_P="${PN}-00${PV}"
@@ -11,45 +11,30 @@ DESCRIPTION="ReplicatorG is a simple, open source 3D printing program"
HOMEPAGE="http://replicat.org/start https://github.com/makerbot/ReplicatorG"
SRC_URI="https://replicatorg.googlecode.com/files/${MY_P}-linux.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
-
IUSE=""
-COMMON_DEPEND="dev-java/oracle-jre-bin"
+COMMON_DEPEND="dev-java/oracle-jre-bin:*"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
S="${WORKDIR}/${MY_P}"
+QA_WX_LOAD="
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/f319e78215d06c9bbdc612ed9aef7e56/SSLeay.so
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/80ccae99bc6b1afe192d6aa7724673cf/SSLeay.so"
+QA_TEXTRELS="
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/f319e78215d06c9bbdc612ed9aef7e56/SSLeay.so
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/80ccae99bc6b1afe192d6aa7724673cf/SSLeay.so
+ /opt/replicatorg/lib-i686/libj3dcore-ogl.so
+ /opt/replicatorg/lib-i686/libj3dcore-ogl-cg.so"
+
pkg_setup() {
enewgroup replicator
}
-pkg_postinst() {
- elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
- elog
- elog "Ensure that your user account has permissions to access serial port,"
- elog "if you plan to connect directly to a 3d printer rather than using"
- elog "a flash card. Printing directly from replicatorg is preferred."
- elog
- elog "The replicator printer will likely show up in /dev as ttyACM0."
- elog "You may want to autoload the cdc_acm kernel module."
- elog
- elog "Note that replicatorg includes its own version of skeinforge."
- elog "There doesn't seem to be a simple way to depend on an external"
- elog "version."
- elog
- elog "Replicatorg users should add themselves to the replicator group"
- elog "to avoid upstream warnings about not being able to modify shared"
- elog "skeinforge scripts."
- elog
- chmod -R g+w "${ROOT}"/opt/replicatorg
- chown -R root:replicator "${ROOT}"/opt/replicatorg
- chmod 0755 /opt/replicatorg
-}
-
src_install() {
dodir \
/opt/replicatorg \
@@ -61,7 +46,8 @@ src_install() {
dobin "${FILESDIR}"/replicatorg
- /bin/cp -R --preserve=mode \
+ insinto /opt/replicatorg/
+ doins -r \
docs \
examples \
lib \
@@ -71,8 +57,7 @@ src_install() {
scripts \
replicatorg \
skein_engines \
- tools \
- "${D}"/opt/replicatorg/
+ tools
insinto /usr/share/replicatorg
doins -r \
@@ -80,5 +65,28 @@ src_install() {
license.txt \
readme.txt \
todo.txt
+}
+pkg_postinst() {
+ elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
+ elog
+ elog "Ensure that your user account has permissions to access serial port,"
+ elog "if you plan to connect directly to a 3d printer rather than using"
+ elog "a flash card. Printing directly from replicatorg is preferred."
+ elog
+ elog "The replicator printer will likely show up in /dev as ttyACM0."
+ elog "You may want to autoload the cdc_acm kernel module."
+ elog
+ elog "Note that replicatorg includes its own version of skeinforge."
+ elog "There doesn't seem to be a simple way to depend on an external"
+ elog "version."
+ elog
+ elog "Replicatorg users should add themselves to the replicator group"
+ elog "to avoid upstream warnings about not being able to modify shared"
+ elog "skeinforge scripts."
+ elog
+
+ chmod -R g+w "${EROOT%/}"/opt/replicatorg
+ chown -R root:replicator "${EROOT%/}"/opt/replicatorg
+ chmod 0755 /opt/replicatorg
}
diff --git a/media-gfx/replicatorg/replicatorg-40-r1.ebuild b/media-gfx/replicatorg/replicatorg-40-r1.ebuild
index 2653c8696e89..217806f00c47 100644
--- a/media-gfx/replicatorg/replicatorg-40-r1.ebuild
+++ b/media-gfx/replicatorg/replicatorg-40-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="3"
+EAPI=6
-inherit eutils versionator user
+inherit versionator user
MY_P="${PN}-00${PV}"
@@ -11,45 +11,30 @@ DESCRIPTION="ReplicatorG is a simple, open source 3D printing program"
HOMEPAGE="http://replicat.org/start https://github.com/makerbot/ReplicatorG"
SRC_URI="https://replicatorg.googlecode.com/files/${MY_P}-linux.tgz"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS=""
-
IUSE=""
-COMMON_DEPEND="dev-java/oracle-jre-bin"
+COMMON_DEPEND="dev-java/oracle-jre-bin:*"
RDEPEND="${COMMON_DEPEND}"
DEPEND="${COMMON_DEPEND}"
S="${WORKDIR}/${MY_P}"
+QA_WX_LOAD="
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/f319e78215d06c9bbdc612ed9aef7e56/SSLeay.so
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/80ccae99bc6b1afe192d6aa7724673cf/SSLeay.so"
+QA_TEXTRELS="
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/f319e78215d06c9bbdc612ed9aef7e56/SSLeay.so
+ /opt/replicatorg/skein_engines/slic3r_engines/linux/lib/vrt/80ccae99bc6b1afe192d6aa7724673cf/SSLeay.so
+ /opt/replicatorg/lib-i686/libj3dcore-ogl.so
+ /opt/replicatorg/lib-i686/libj3dcore-ogl-cg.so"
+
pkg_setup() {
enewgroup replicator
}
-pkg_postinst() {
- elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
- elog
- elog "Ensure that your user account has permissions to access serial port,"
- elog "if you plan to connect directly to a 3d printer rather than using"
- elog "a flash card. Printing directly from replicatorg is preferred."
- elog
- elog "The replicator printer will likely show up in /dev as ttyACM0."
- elog "You may want to autoload the cdc_acm kernel module."
- elog
- elog "Note that replicatorg includes its own version of skeinforge."
- elog "There doesn't seem to be a simple way to depend on an external"
- elog "version."
- elog
- elog "Replicatorg users should add themselves to the replicator group"
- elog "to avoid upstream warnings about not being able to modify shared"
- elog "skeinforge scripts."
- elog
- chmod -R g+w "${ROOT}"/opt/replicatorg
- chown -R root:replicator "${ROOT}"/opt/replicatorg
- chmod 0755 /opt/replicatorg
-}
-
src_install() {
dodir \
/opt/replicatorg \
@@ -61,7 +46,8 @@ src_install() {
dobin "${FILESDIR}"/replicatorg
- /bin/cp -R --preserve=mode \
+ insinto /opt/replicatorg/
+ doins -r \
docs \
examples \
lib \
@@ -71,8 +57,7 @@ src_install() {
scripts \
replicatorg \
skein_engines \
- tools \
- "${D}"/opt/replicatorg/
+ tools
insinto /usr/share/replicatorg
doins -r \
@@ -80,5 +65,28 @@ src_install() {
license.txt \
readme.txt \
todo.txt
+}
+pkg_postinst() {
+ elog "Replicatorg requires Sun/Oracle JRE and will not work with OpenJDK."
+ elog
+ elog "Ensure that your user account has permissions to access serial port,"
+ elog "if you plan to connect directly to a 3d printer rather than using"
+ elog "a flash card. Printing directly from replicatorg is preferred."
+ elog
+ elog "The replicator printer will likely show up in /dev as ttyACM0."
+ elog "You may want to autoload the cdc_acm kernel module."
+ elog
+ elog "Note that replicatorg includes its own version of skeinforge."
+ elog "There doesn't seem to be a simple way to depend on an external"
+ elog "version."
+ elog
+ elog "Replicatorg users should add themselves to the replicator group"
+ elog "to avoid upstream warnings about not being able to modify shared"
+ elog "skeinforge scripts."
+ elog
+
+ chmod -R g+w "${EROOT%/}"/opt/replicatorg
+ chown -R root:replicator "${EROOT%/}"/opt/replicatorg
+ chmod 0755 /opt/replicatorg
}