summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/faun/faun-0.1.2.ebuild')
-rw-r--r--media-libs/faun/faun-0.1.2.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-libs/faun/faun-0.1.2.ebuild b/media-libs/faun/faun-0.1.2.ebuild
index bf49a3d73f7a..a5b0eb2e7089 100644
--- a/media-libs/faun/faun-0.1.2.ebuild
+++ b/media-libs/faun/faun-0.1.2.ebuild
@@ -1,13 +1,16 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit edo toolchain-funcs
+
DESCRIPTION="A high-level C audio library"
HOMEPAGE="https://wickedsmoke.github.io/faun/"
SRC_URI="https://github.com/WickedSmoke/faun/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2 MIT"
+# based on COPYING file
+LICENSE="MIT flac? ( GPL-2 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="flac"
@@ -19,12 +22,13 @@ DEPEND="
RDEPEND="${DEPEND}"
PATCHES=(
- "${FILESDIR}/0.1.2_makefile.patch"
+ "${FILESDIR}/${PN}-0.1.2_makefile.patch"
)
src_configure() {
+ tc-export CC
# custom configure
- ./configure $(usex !flac --no_flac "") || die
+ edo ./configure $(usex !flac --no_flac "")
}
src_install() {