summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/faun/faun-0.1.2.ebuild')
-rw-r--r--media-libs/faun/faun-0.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/faun/faun-0.1.2.ebuild b/media-libs/faun/faun-0.1.2.ebuild
new file mode 100644
index 000000000000..bf49a3d73f7a
--- /dev/null
+++ b/media-libs/faun/faun-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A high-level C audio library"
+HOMEPAGE="https://wickedsmoke.github.io/faun/"
+SRC_URI="https://github.com/WickedSmoke/faun/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="flac"
+
+DEPEND="
+ media-libs/libpulse
+ media-libs/libvorbis
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/0.1.2_makefile.patch"
+)
+
+src_configure() {
+ # custom configure
+ ./configure $(usex !flac --no_flac "") || die
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" install
+ dodoc README.md
+}