summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lastfmlib')
-rw-r--r--media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch20
-rw-r--r--media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild34
2 files changed, 54 insertions, 0 deletions
diff --git a/media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch b/media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch
new file mode 100644
index 000000000000..381e731d9f62
--- /dev/null
+++ b/media-libs/lastfmlib/files/lastfmlib-0.4.0-string-conv.patch
@@ -0,0 +1,20 @@
+# Fix string conversions
+# Author: Steven Newbury <steve@snewbury.org.uk>
+# Gentoo Bug: 664760
+--- ./lastfmlib/utils/stringoperations.h~ 2020-02-27 11:50:53.000000000 +0000
++++ ./lastfmlib/utils/stringoperations.h 2020-02-27 11:55:49.228128570 +0000
+@@ -53,14 +53,6 @@
+ ss << numeric;
+ return ss.str();
+ }
+-
+- template<typename T>
+- inline std::string toWstring(T& numeric)
+- {
+- std::wstringstream ss;
+- ss << numeric;
+- return ss.str();
+- }
+ }
+
+ #endif
diff --git a/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..f10290636479
--- /dev/null
+++ b/media-libs/lastfmlib/lastfmlib-0.4.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ library to scrobble tracks on Last.fm"
+HOMEPAGE="https://github.com/dirkvdb/lastfmlib/releases"
+SRC_URI="https://github.com/dirkvdb/lastfmlib/archive/lastfmlib-0.4.0.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug syslog"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-string-conv.patch"
+)
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable syslog logging) \
+ --disable-unittests
+}
+
+src_install() {
+ default
+ find "${D}"/usr -name '*.la' -delete || die "Pruning failed"
+}