summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libvisio')
-rw-r--r--media-libs/libvisio/Manifest3
-rw-r--r--media-libs/libvisio/libvisio-0.0.30.ebuild53
-rw-r--r--media-libs/libvisio/libvisio-0.1.1.ebuild54
-rw-r--r--media-libs/libvisio/libvisio-0.1.3.ebuild55
-rw-r--r--media-libs/libvisio/libvisio-9999.ebuild55
-rw-r--r--media-libs/libvisio/metadata.xml8
6 files changed, 228 insertions, 0 deletions
diff --git a/media-libs/libvisio/Manifest b/media-libs/libvisio/Manifest
new file mode 100644
index 000000000000..88298e9c2a20
--- /dev/null
+++ b/media-libs/libvisio/Manifest
@@ -0,0 +1,3 @@
+DIST libvisio-0.0.30.tar.xz 384508 SHA256 e7be89fdef23483deea53a557fe023c9f6b59e0f7bb5ba4f42b5909c86cc11f9 SHA512 d0261f30ca9065873aa498f7594a638d0a90dadd4df609a91e746579d14b5f1f18aa4e4812d25870b390f2df59ffa8f8a4d76618c6e71539023b7610044c9d21 WHIRLPOOL 1e328569f3e810c6cc1399015b7fb5b4aa206e0127109efaad23163fba8d45a4a74945ff6cca3dcc883dcd1248be69149383a2d9f44fb5be213ebfcd2574a92e
+DIST libvisio-0.1.1.tar.xz 412752 SHA256 4b510168d1465516fdf6e57c01e2f9eae1fc0ae232c74e44e70693bbc49227f1 SHA512 c17c3a94985bd4c6fb10fc27d1b61ac812d5b663d123d2a5a5089f9297d39c53befffd563e6367aa024df7f69c03a1cfa41edef71c824cf03e26e3b01987dd38 WHIRLPOOL 47b81e6f4ad9f6267113d259f3d9514751fd73a731ded9b265dddbaa918bee5be1a1580ced9ceb287822ee8a67841f15ca06e04d300212301ae5549625589cfa
+DIST libvisio-0.1.3.tar.xz 479592 SHA256 943e03b1e6c969af4c2133a6671c9630adf3aaf8d460156744a28f58c9f47cd8 SHA512 aa7ea66d30b54e70acd6684a861923dd5979025e5fda12e1e777c6e7a461f9691f2df1dd67ea4599dbb7e0293df0eee9dc9848f79067c4058afb090717489d35 WHIRLPOOL db483c052f69d1874681d36bac98bb7d65f6fd1cd2e8650fc2be0be1705b51dc43a79ad306eafacf11f4463e2e1a18776c3b5e5b0aefc7f92f5eb718aee50e04
diff --git a/media-libs/libvisio/libvisio-0.0.30.ebuild b/media-libs/libvisio/libvisio-0.0.30.ebuild
new file mode 100644
index 000000000000..3ed8b0cf03c4
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.0.30.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/contrib/libvisio/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+ dev-libs/icu:=
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libvisio/libvisio-0.1.1.ebuild b/media-libs/libvisio/libvisio-0.1.1.ebuild
new file mode 100644
index 000000000000..729741b838b5
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-2
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="amd64 ~arm ~hppa ~ppc64 x86"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libvisio/libvisio-0.1.3.ebuild b/media-libs/libvisio/libvisio-0.1.3.ebuild
new file mode 100644
index 000000000000..591d1b34eb80
--- /dev/null
+++ b/media-libs/libvisio/libvisio-0.1.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="doc static-libs test tools"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libvisio/libvisio-9999.ebuild b/media-libs/libvisio/libvisio-9999.ebuild
new file mode 100644
index 000000000000..591d1b34eb80
--- /dev/null
+++ b/media-libs/libvisio/libvisio-9999.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/libreoffice/libvisio/"
+inherit base eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing the visio documents"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libvisio"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
+IUSE="doc static-libs test tools"
+
+RDEPEND="
+ dev-libs/icu:=
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ dev-util/gperf
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ [[ -d m4 ]] || mkdir "m4"
+ base_src_prepare
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable static-libs static) \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable test tests) \
+ $(use_enable tools)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/media-libs/libvisio/metadata.xml b/media-libs/libvisio/metadata.xml
new file mode 100644
index 000000000000..96e7f4f60d1e
--- /dev/null
+++ b/media-libs/libvisio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>openoffice</herd>
+ <use>
+ <flag name="tools">Build conversion tools</flag>
+ </use>
+</pkgmetadata>