summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/munt-mt32emu/munt-mt32emu-2.5.3-r1.ebuild')
-rw-r--r--media-libs/munt-mt32emu/munt-mt32emu-2.5.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/munt-mt32emu/munt-mt32emu-2.5.3-r1.ebuild b/media-libs/munt-mt32emu/munt-mt32emu-2.5.3-r1.ebuild
new file mode 100644
index 000000000000..69e3f2578ea5
--- /dev/null
+++ b/media-libs/munt-mt32emu/munt-mt32emu-2.5.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+MY_P="libmt32emu_${PV//./_}"
+DESCRIPTION="Library for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I"
+HOMEPAGE="https://github.com/munt/munt"
+SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/munt-${MY_P}/mt32emu"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.2-docs.patch
+)
+
+src_configure() {
+ local libdir=${EPREFIX}/usr/$(get_libdir)
+
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${libdir}"
+ -Dlibmt32emu_PKGCONFIG_INSTALL_PREFIX="${libdir}"
+ )
+
+ cmake_src_configure
+}