summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opencore-amr')
-rw-r--r--media-libs/opencore-amr/opencore-amr-0.1.5-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/media-libs/opencore-amr/opencore-amr-0.1.5-r1.ebuild b/media-libs/opencore-amr/opencore-amr-0.1.5-r1.ebuild
new file mode 100644
index 000000000000..425e4b64b2cf
--- /dev/null
+++ b/media-libs/opencore-amr/opencore-amr-0.1.5-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Implementation of Adaptive Multi Rate Narrowband and Wideband speech codec"
+HOMEPAGE="https://sourceforge.net/projects/opencore-amr/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf --disable-static
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name "*.la" -delete || die
+}