summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/opensubdiv/files')
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.4.0-0001-documentation-CMakeLists.txt-force-python2.patch51
-rw-r--r--media-libs/opensubdiv/files/opensubdiv-3.4.3-install-tutorials-into-bin.patch52
2 files changed, 103 insertions, 0 deletions
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.4.0-0001-documentation-CMakeLists.txt-force-python2.patch b/media-libs/opensubdiv/files/opensubdiv-3.4.0-0001-documentation-CMakeLists.txt-force-python2.patch
new file mode 100644
index 000000000000..5455ba98e317
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.4.0-0001-documentation-CMakeLists.txt-force-python2.patch
@@ -0,0 +1,51 @@
+From dc9d14c97fc22ad5b00c9ffb0f83931e42cf2eb0 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Fri, 2 Aug 2019 19:27:17 +0200
+Subject: [PATCH] documentation/CMakeLists.txt: force python2
+
+The patch forces to use Python-2.x to build the documentation
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ documentation/CMakeLists.txt | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/documentation/CMakeLists.txt b/documentation/CMakeLists.txt
+index 32b12a3..a93414e 100644
+--- a/documentation/CMakeLists.txt
++++ b/documentation/CMakeLists.txt
+@@ -54,10 +54,10 @@ else()
+
+ endif()
+
+-find_package(PythonInterp 2.6)
++find_package(Python2 COMPONENTS Interpreter)
+
+ # ReST - HTML documentation
+-if (DOCUTILS_FOUND AND PYTHONINTERP_FOUND)
++if (DOCUTILS_FOUND AND Python2_Interpreter_FOUND)
+
+ set(HTML_FILES
+ search.html
+@@ -198,7 +198,7 @@ if (DOCUTILS_FOUND AND PYTHONINTERP_FOUND)
+ OUTPUT
+ "${rstfile}"
+ COMMAND
+- "${PYTHON_EXECUTABLE}"
++ "${Python2_EXECUTABLE}"
+ ARGS
+ "${CMAKE_CURRENT_SOURCE_DIR}/processTutorials.py"
+ "${infile}"
+@@ -291,7 +291,7 @@ if (DOCUTILS_FOUND AND PYTHONINTERP_FOUND)
+ # build search index and insert navigation tab
+ add_custom_target(search_index
+ COMMAND
+- "${PYTHON_EXECUTABLE}"
++ "${Python2_EXECUTABLE}"
+ "${CMAKE_CURRENT_SOURCE_DIR}/processHtml.py"
+ "${CMAKE_CURRENT_BINARY_DIR}"
+ "${CMAKE_CURRENT_SOURCE_DIR}/nav_template.txt"
+--
+2.22.0
+
+
diff --git a/media-libs/opensubdiv/files/opensubdiv-3.4.3-install-tutorials-into-bin.patch b/media-libs/opensubdiv/files/opensubdiv-3.4.3-install-tutorials-into-bin.patch
new file mode 100644
index 000000000000..f042967a01af
--- /dev/null
+++ b/media-libs/opensubdiv/files/opensubdiv-3.4.3-install-tutorials-into-bin.patch
@@ -0,0 +1,52 @@
+diff -Naur a/tutorials/far/CMakeLists.txt b/tutorials/far/CMakeLists.txt
+--- a/tutorials/far/CMakeLists.txt 2020-05-11 14:48:35.145797436 +1000
++++ b/tutorials/far/CMakeLists.txt 2020-05-11 14:49:39.445969003 +1000
+@@ -30,7 +30,7 @@
+ $<TARGET_OBJECTS:far_obj>
+ )
+
+- install(TARGETS ${NAME} DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++ install(TARGETS ${NAME} DESTINATION "${CMAKE_BINDIR_BASE}")
+
+ endmacro()
+
+diff -Naur a/tutorials/hbr/tutorial_0/CMakeLists.txt b/tutorials/hbr/tutorial_0/CMakeLists.txt
+--- a/tutorials/hbr/tutorial_0/CMakeLists.txt 2020-05-11 14:48:35.145797436 +1000
++++ b/tutorials/hbr/tutorial_0/CMakeLists.txt 2020-05-11 14:50:38.076125987 +1000
+@@ -30,5 +30,5 @@
+ ${SOURCE_FILES}
+ )
+
+-install(TARGETS hbr_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS hbr_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/hbr/tutorial_1/CMakeLists.txt b/tutorials/hbr/tutorial_1/CMakeLists.txt
+--- a/tutorials/hbr/tutorial_1/CMakeLists.txt 2020-05-11 14:48:35.145797436 +1000
++++ b/tutorials/hbr/tutorial_1/CMakeLists.txt 2020-05-11 14:50:10.406051839 +1000
+@@ -30,5 +30,5 @@
+ ${SOURCE_FILES}
+ )
+
+-install(TARGETS hbr_tutorial_1 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS hbr_tutorial_1 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/hbr/tutorial_2/CMakeLists.txt b/tutorials/hbr/tutorial_2/CMakeLists.txt
+--- a/tutorials/hbr/tutorial_2/CMakeLists.txt 2020-05-11 14:48:35.145797436 +1000
++++ b/tutorials/hbr/tutorial_2/CMakeLists.txt 2020-05-11 14:50:20.706079428 +1000
+@@ -30,5 +30,5 @@
+ ${SOURCE_FILES}
+ )
+
+-install(TARGETS hbr_tutorial_2 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS hbr_tutorial_2 DESTINATION "${CMAKE_BINDIR_BASE}")
+
+diff -Naur a/tutorials/osd/tutorial_0/CMakeLists.txt b/tutorials/osd/tutorial_0/CMakeLists.txt
+--- a/tutorials/osd/tutorial_0/CMakeLists.txt 2020-05-11 14:48:35.145797436 +1000
++++ b/tutorials/osd/tutorial_0/CMakeLists.txt 2020-05-11 14:50:51.446161856 +1000
+@@ -35,5 +35,5 @@
+ osd_static_cpu
+ )
+
+-install(TARGETS osd_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}/tutorials")
++install(TARGETS osd_tutorial_0 DESTINATION "${CMAKE_BINDIR_BASE}")
+