summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/ptex/files/ptex-2.3.0-cxx11.patch')
-rw-r--r--media-libs/ptex/files/ptex-2.3.0-cxx11.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/media-libs/ptex/files/ptex-2.3.0-cxx11.patch b/media-libs/ptex/files/ptex-2.3.0-cxx11.patch
new file mode 100644
index 000000000000..f0b600091377
--- /dev/null
+++ b/media-libs/ptex/files/ptex-2.3.0-cxx11.patch
@@ -0,0 +1,12 @@
+diff -purN a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-04-04 18:14:05.000000000 +0100
++++ b/CMakeLists.txt 2017-02-13 22:59:10.000000000 +0000
+@@ -16,7 +16,7 @@ else ()
+ endif ()
+
+ if (NOT WIN32)
+- set(CMAKE_CXX_FLAGS "-std=c++98 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
++ set(CMAKE_CXX_FLAGS "-std=c++11 -Wall -Wextra -pedantic ${CMAKE_CXX_FLAGS}")
+ endif ()
+
+ if(MSVC)