summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/speex/files/speex-1.2_rc1-configure.patch')
-rw-r--r--media-libs/speex/files/speex-1.2_rc1-configure.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-libs/speex/files/speex-1.2_rc1-configure.patch b/media-libs/speex/files/speex-1.2_rc1-configure.patch
new file mode 100644
index 000000000000..cd780daf261e
--- /dev/null
+++ b/media-libs/speex/files/speex-1.2_rc1-configure.patch
@@ -0,0 +1,31 @@
+diff -ur speex-1.2rc1.orig/configure.ac speex-1.2rc1/configure.ac
+--- speex-1.2rc1.orig/configure.ac 2008-07-30 22:49:17.000000000 -0400
++++ speex-1.2rc1/configure.ac 2008-07-30 22:50:33.000000000 -0400
+@@ -112,9 +112,6 @@
+
+ AC_CHECK_HEADERS(sys/soundcard.h sys/audioio.h)
+
+-XIPH_PATH_OGG([src="src"], [src=""])
+-AC_SUBST(src)
+-
+ AC_CHECK_LIB(m, sin)
+
+ # Check for getopt_long; if not found, use included source.
+@@ -139,10 +136,16 @@
+ AC_DEFINE([ENABLE_VALGRIND], , [Enable valgrind extra checks])
+ fi])
+
++AC_ARG_ENABLE(ogg, [ --enable-ogg Enable OGG support], [if test "$enableval" = yes; then
++ XIPH_PATH_OGG([src="src"], [src=""])
++ AC_SUBST(src)
++fi
++])
++
+ AC_ARG_ENABLE(sse, [ --enable-sse Enable SSE support], [
+ if test "x$enableval" != xno; then
+ has_sse=yes
+-CFLAGS="$CFLAGS -O3 -msse"
++CFLAGS="$CFLAGS -msse"
+ else
+ has_sse=no
+ fi