summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x264/x264-0.0.20151011.ebuild')
-rw-r--r--media-libs/x264/x264-0.0.20151011.ebuild74
1 files changed, 0 insertions, 74 deletions
diff --git a/media-libs/x264/x264-0.0.20151011.ebuild b/media-libs/x264/x264-0.0.20151011.ebuild
deleted file mode 100644
index f097db63aed7..000000000000
--- a/media-libs/x264/x264-0.0.20151011.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit flag-o-matic multilib toolchain-funcs eutils multilib-minimal
-
-DESCRIPTION="A free library for encoding X264/AVC streams"
-HOMEPAGE="http://www.videolan.org/developers/x264.html"
-if [[ ${PV} == 9999 ]]; then
- inherit git-2
- EGIT_REPO_URI="git://git.videolan.org/x264.git"
-else
- inherit versionator
- MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
- SRC_URI="http://download.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
- KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
- S="${WORKDIR}/${MY_P}"
-fi
-
-SONAME="148"
-SLOT="0/${SONAME}"
-
-LICENSE="GPL-2"
-IUSE="10bit +interlaced opencl pic static-libs cpu_flags_x86_sse +threads"
-
-ASM_DEP=">=dev-lang/yasm-1.2.0"
-DEPEND="abi_x86_32? ( ${ASM_DEP} )
- abi_x86_64? ( ${ASM_DEP} )
- opencl? ( dev-lang/perl )"
-RDEPEND="opencl? ( >=virtual/opencl-0-r3[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r7
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
-
-DOCS="AUTHORS doc/*.txt"
-
-src_prepare() {
- # Initial support for x32 ABI, bug #420241
- # Avoid messing too much with CFLAGS.
- epatch "${FILESDIR}"/x264-0.0.20151011-cflags.patch
-}
-
-multilib_src_configure() {
- tc-export CC
- local asm_conf=""
-
- if [[ ${ABI} == x86* ]] && use pic || [[ ${ABI} == "x32" ]]; then
- asm_conf=" --disable-asm"
- fi
-
- # Upstream uses this, see the cflags patch
- use cpu_flags_x86_sse && append-flags "-msse" "-mfpmath=sse"
- append-flags "-ffast-math"
-
- "${S}/configure" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --disable-cli \
- --disable-avs \
- --disable-lavf \
- --disable-swscale \
- --disable-ffms \
- --disable-gpac \
- --enable-pic \
- --enable-shared \
- --host="${CHOST}" \
- $(usex 10bit "--bit-depth=10" "") \
- $(usex interlaced "" "--disable-interlaced") \
- $(usex opencl "" "--disable-opencl") \
- $(usex static-libs "--enable-static" "") \
- $(usex threads "" "--disable-thread") \
- ${asm_conf} || die
-}