summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x265/x265-3.0.ebuild')
-rw-r--r--media-libs/x265/x265-3.0.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/media-libs/x265/x265-3.0.ebuild b/media-libs/x265/x265-3.0.ebuild
index 2d1942d399d2..df633a2e1d7f 100644
--- a/media-libs/x265/x265-3.0.ebuild
+++ b/media-libs/x265/x265-3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -19,7 +19,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/169"
-IUSE="+10bit +12bit cpu_flags_arm_neon numa pic power8 test"
+IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
RESTRICT="!test? ( test )"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
@@ -142,8 +142,8 @@ multilib_src_configure() {
$(cmake-utils_use_enable test TESTS)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
-DENABLE_LIBNUMA=$(usex numa ON OFF)
- -DCPU_POWER8=$(usex power8 ON OFF)
- -DENABLE_ALTIVEC=$(usex power8 ON OFF)
+ -DCPU_POWER8=$(usex cpu_flags_ppc_vsx2 ON OFF)
+ -DENABLE_ALTIVEC=$(usex cpu_flags_ppc_vsx2 ON OFF)
-DLIB_INSTALL_DIR="$(get_libdir)"
)