summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x265/x265-9999.ebuild')
-rw-r--r--media-libs/x265/x265-9999.ebuild33
1 files changed, 17 insertions, 16 deletions
diff --git a/media-libs/x265/x265-9999.ebuild b/media-libs/x265/x265-9999.ebuild
index d686f028c1da..8be9f4a93e84 100644
--- a/media-libs/x265/x265-9999.ebuild
+++ b/media-libs/x265/x265-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake multilib-minimal multilib multibuild flag-o-matic
+inherit cmake flag-o-matic multilib-minimal multibuild
if [[ ${PV} = 9999* ]]; then
inherit git-r3
@@ -11,7 +11,7 @@ if [[ ${PV} = 9999* ]]; then
S=${WORKDIR}/${P}/source
else
SRC_URI="https://bitbucket.org/multicoreware/x265_git/downloads/${PN}_${PV}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~x86"
fi
DESCRIPTION="Library for encoding video streams into the H.265/HEVC format"
@@ -19,8 +19,8 @@ HOMEPAGE="http://x265.org/ https://bitbucket.org/multicoreware/x265_git/"
LICENSE="GPL-2"
# subslot = libx265 soname
-SLOT="0/199"
-IUSE="+10bit +12bit cpu_flags_arm_neon cpu_flags_ppc_vsx2 numa pic test"
+SLOT="0/208"
+IUSE="+10bit +12bit cpu_flags_ppc_vsx2 numa test"
RESTRICT="!test? ( test )"
RDEPEND="numa? ( >=sys-process/numactl-2.0.10-r1[${MULTILIB_USEDEP}] )"
@@ -32,10 +32,9 @@ BDEPEND="
PATCHES=(
"${FILESDIR}/${PN}-9999-arm.patch"
- #"${FILESDIR}/neon.patch"
- "${FILESDIR}/${PN}-9999-ppc64.patch"
+ "${FILESDIR}/neon.patch"
"${FILESDIR}/tests.patch"
- "${FILESDIR}/test-ns.patch"
+ "${FILESDIR}/${PN}-9999-test-ns.patch"
)
src_unpack() {
@@ -157,6 +156,11 @@ x265_variant_src_configure() {
}
multilib_src_configure() {
+ # -Werror=odr
+ # https://bugs.gentoo.org/875854
+ # https://bitbucket.org/multicoreware/x265_git/issues/937/build-fails-with-lto
+ filter-lto
+
local myabicmakeargs=(
-DENABLE_TESTS=$(usex test ON OFF)
$(multilib_is_native_abi || echo "-DENABLE_CLI=OFF")
@@ -166,18 +170,15 @@ multilib_src_configure() {
-DLIB_INSTALL_DIR="$(get_libdir)"
)
+ # Unfortunately, the asm for x86/x32/arm isn't PIC-safe.
if [[ ${ABI} = x86 ]] ; then
- # Bug #528202
- if use pic ; then
- ewarn "PIC has been requested but x86 asm is not PIC-safe, disabling it."
- myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
- fi
+ # Bug #528202, bug #913412
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
elif [[ ${ABI} = x32 ]] ; then
# bug #510890
myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
elif [[ ${ABI} = arm ]] ; then
- myabicmakeargs+=( -DENABLE_ASSEMBLY=$(usex pic OFF $(usex cpu_flags_arm_neon ON OFF)) )
- use cpu_flags_arm_neon && use pic && ewarn "PIC has been requested but arm neon asm is not PIC-safe, disabling it."
+ myabicmakeargs+=( -DENABLE_ASSEMBLY=OFF )
fi
local MULTIBUILD_VARIANTS=( $(x265_get_variants) )