summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/munt-mt32emu/Manifest1
-rw-r--r--media-libs/munt-mt32emu/files/docs.patch27
-rw-r--r--media-libs/munt-mt32emu/metadata.xml15
-rw-r--r--media-libs/munt-mt32emu/munt-mt32emu-2.3.0.ebuild28
4 files changed, 71 insertions, 0 deletions
diff --git a/media-libs/munt-mt32emu/Manifest b/media-libs/munt-mt32emu/Manifest
new file mode 100644
index 000000000000..c34079940fcf
--- /dev/null
+++ b/media-libs/munt-mt32emu/Manifest
@@ -0,0 +1 @@
+DIST munt_2_3_0.tar.gz 418703 BLAKE2B d9c4290f11f4114b26aa45d6591c04a73d56981e7f618c1466db81fd35be3588b2853fb60b9cf65dd523ce8ea120a5a187bd805b58ba2f75719d460929c2e4e1 SHA512 87fe4891628ea33967270fe3c6c3840e40deb14bd7c8d61490d4c0057438af6bc0099c10e24e813ef1613ca9cc9fc1567a0340c7ea1f4254b209f7fc99c8c7a1
diff --git a/media-libs/munt-mt32emu/files/docs.patch b/media-libs/munt-mt32emu/files/docs.patch
new file mode 100644
index 000000000000..20034b933641
--- /dev/null
+++ b/media-libs/munt-mt32emu/files/docs.patch
@@ -0,0 +1,27 @@
+From 43b3a932650ffd52fc1bc56f5c515ee4855bfd79 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Mon, 22 Jan 2018 21:07:52 +0000
+Subject: [PATCH] Install documentation in Gentoo-compliant manner
+
+---
+ mt32emu/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mt32emu/CMakeLists.txt b/mt32emu/CMakeLists.txt
+index 248f576..704d4f9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -251,8 +251,8 @@ endif()
+
+ if(libmt32emu_PACKAGE_TYPE STREQUAL "Runtime" OR NOT libmt32emu_PACKAGE_TYPE STREQUAL "Devel")
+ install(FILES
+- AUTHORS.txt COPYING.txt COPYING.LESSER.txt NEWS.txt README.txt TODO.txt
+- DESTINATION share/doc/munt/libmt32emu
++ AUTHORS.txt NEWS.txt README.txt TODO.txt
++ DESTINATION share/doc/$ENV{PF}
+ )
+ endif()
+
+--
+2.15.0
+
diff --git a/media-libs/munt-mt32emu/metadata.xml b/media-libs/munt-mt32emu/metadata.xml
new file mode 100644
index 000000000000..168b3b7149fc
--- /dev/null
+++ b/media-libs/munt-mt32emu/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chewi@gentoo.org</email>
+ <name>James Le Cuirot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">munt</remote-id>
+ <remote-id type="github">munt/munt</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ A multi-platform software synthesiser emulating (currently inaccurately) pre-GM MIDI devices such as the Roland MT-32, CM-32L, CM-64 and LAPC-I. In no way endorsed by or affiliated with Roland Corp.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-libs/munt-mt32emu/munt-mt32emu-2.3.0.ebuild b/media-libs/munt-mt32emu/munt-mt32emu-2.3.0.ebuild
new file mode 100644
index 000000000000..8e19616aa4da
--- /dev/null
+++ b/media-libs/munt-mt32emu/munt-mt32emu-2.3.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+MY_P="munt_${PV//./_}"
+DESCRIPTION="Library for emulating the Roland MT-32, CM-32L, CM-64 and LAPC-I"
+HOMEPAGE="https://github.com/munt/munt"
+SRC_URI="https://github.com/munt/munt/archive/${MY_P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/munt-${MY_P}/mt32emu"
+
+PATCHES=(
+ "${FILESDIR}"/docs.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+ )
+
+ cmake-utils_src_configure
+}