summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/liblo/Manifest1
-rw-r--r--media-libs/liblo/liblo-0.30.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/liblo/Manifest b/media-libs/liblo/Manifest
index 05008a7d0b6d..3f680f0d105d 100644
--- a/media-libs/liblo/Manifest
+++ b/media-libs/liblo/Manifest
@@ -1 +1,2 @@
DIST liblo-0.29.tar.gz 645313 BLAKE2B 2ef68c49446c83e13541e626eb666360f4b1b579abd2685a9eeaf18989e0252860a7c2eb99e9f6991210873b60dd4b0a62f4f2adfe88c8ac2e069b41fea0e2d4 SHA512 11e20725a049c55c02ef8cd106be5802507f3df95422d8dad10009bdd1237af7517e3261c7336c3005e21ae8fd1e663badef46e4bae006c7af70520bdb336c7c
+DIST liblo-0.30.tar.gz 641498 BLAKE2B d884cc723d770f45414e838b6f2520c1f3b2a11972a9977d19b20ba68bc653f895eeb21ba0182a09fde1f096c9be084def1572f747463cd71e96bf0022ef7549 SHA512 51132933cc23237b70ed08fa7986a4a9f838529b83807746b358bcc171f8bbce7f37115b7c855520c9219bae93c74e502aebfb90e44dabdc6d0a00b8335336e3
diff --git a/media-libs/liblo/liblo-0.30.ebuild b/media-libs/liblo/liblo-0.30.ebuild
new file mode 100644
index 000000000000..77076911f198
--- /dev/null
+++ b/media-libs/liblo/liblo-0.30.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Lightweight OSC (Open Sound Control) implementation"
+HOMEPAGE="https://sourceforge.net/projects/liblo/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos"
+IUSE="doc ipv6 static-libs"
+
+RESTRICT="test"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ # don't build examples by default
+ sed -i '/^SUBDIRS =/s/examples//' Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ use doc || export ac_cv_prog_HAVE_DOXYGEN=false
+
+ # switching threads on/off breaks ABI, bugs #473282, #473286 and #473356
+ myeconfargs=(
+ --enable-threads
+ $(use_enable ipv6)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+}