summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/nas/Manifest1
-rw-r--r--media-libs/nas/files/nas-1.9.4-fno-config.patch42
-rw-r--r--media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch36
-rw-r--r--media-libs/nas/nas-1.9.4-r2.ebuild115
4 files changed, 0 insertions, 194 deletions
diff --git a/media-libs/nas/Manifest b/media-libs/nas/Manifest
index ec48daf7ff4a..350414fb2ed0 100644
--- a/media-libs/nas/Manifest
+++ b/media-libs/nas/Manifest
@@ -1,2 +1 @@
-DIST nas-1.9.4.src.tar.gz 1464598 BLAKE2B d79ecda9f86a89d2d61bfadfeee4bb6a9feca6754bb88249b1eb3c1964e784d18098465f30f1b5bbb13d0550aebf48bb1b98aeb1b7c712f344a2eddc7720531b SHA512 3f8bd60f8ce0f25a2605af17caaadfe4f21223ba4cd3fa02078d1427b17cdf33ebda887e5dc30cd68eb7f64bfad80aafc9071ff0a26f0d3a4a93caacac03b5bb
DIST nas-1.9.5.tar.gz 1170144 BLAKE2B 81b063f888d66534f8779d6b0534397ada703868ff711c49b998fbf56bc6e4313fa245b6168fe9913936afa0685bab595df24f9f4bd5663dfa560c4b64534466 SHA512 051b32593e7ace09cf2d12720fb80e38d4f83f36858debacfb828c759e98b3e29401c76e3e3770f57fbbd1750a84b17a18e712f0de3dbe0ff56f2505c2488d9a
diff --git a/media-libs/nas/files/nas-1.9.4-fno-config.patch b/media-libs/nas/files/nas-1.9.4-fno-config.patch
deleted file mode 100644
index e5ce72d37d9a..000000000000
--- a/media-libs/nas/files/nas-1.9.4-fno-config.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From f1e8e0da221152560efcb097c00539476071047c Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
-Date: Thu, 23 Jan 2020 13:43:12 +0100
-Subject: [PATCH] Fix building with GCC 10
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-GCC 10 defaults to -fno-common and as a result raises an arror when
-linking nasd:
-
-gcc -o nasd -O2 -fno-strict-aliasing -Wl,-z,relro -Wl,--as-needed -Wl,-z,now -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -L../lib/audio -L/usr/lib64 -L/usr/lib64 dia/libdia.a dda/voxware/libvoxware.a os/libos.a
-/usr/bin/ld: dia/libdia.a(lex.o): in function `$d':
-lex.c:(.bss+0x48): multiple definition of `yyin'; dia/libdia.a(main.o):/builddir/build/BUILD/nas-1.9.4/server/dia/main.c:79: first defined here
-collect2: error: ld returned 1 exit status
-
-The reason is that both lex.c (generated from lex.l) and main.c
-define yyin global variable.
-
-This patch changes the main.c definition into a declaration.
-
-Signed-off-by: Petr Písař <ppisar@redhat.com>
----
- server/dia/main.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/server/dia/main.c b/server/dia/main.c
-index 462e89b..9ea2a12 100644
---- a/server/dia/main.c
-+++ b/server/dia/main.c
-@@ -76,7 +76,7 @@ static char *AuServerName(void);
- extern char *display;
-
- static int restart = 0;
--FILE *yyin; /* for the config parser */
-+extern FILE *yyin; /* for the config parser */
-
- void
- NotImplemented()
---
-2.26.2
-
diff --git a/media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch b/media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch
deleted file mode 100644
index 46ef6bb4610e..000000000000
--- a/media-libs/nas/files/nas-1.9.4-remove-abs-fabs.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 212309075d26668f6e25f30754e646952843cf61 Mon Sep 17 00:00:00 2001
-From: "Anthony G. Basile" <blueness@gentoo.org>
-Date: Tue, 28 Apr 2015 18:56:46 -0600
-Subject: [PATCH]
-
-On a uClibc system, the macro definitions of abs() and fabs()
- cause the build to fail. Since these are specified by POSIX, it is safe to
- just drop their definition. This has been tested on uClibc, glibc and musl.
-
-See: https://bugs.gentoo.org/show_bug.cgi?id=510766
-
-Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
----
- server/include/misc.h | 6 ------
- 1 file changed, 6 deletions(-)
-
-diff --git a/server/include/misc.h b/server/include/misc.h
-index 2267ae0..fb904c8 100644
---- a/server/include/misc.h
-+++ b/server/include/misc.h
-@@ -71,12 +71,6 @@ typedef int Bool;
-
- #define min(a, b) (((a) < (b)) ? (a) : (b))
- #define max(a, b) (((a) > (b)) ? (a) : (b))
--#ifndef abs
--#define abs(a) ((a) > 0 ? (a) : -(a))
--#endif
--#ifndef fabs
--#define fabs(a) ((a) > 0.0 ? (a) : -(a)) /* floating absolute value */
--#endif
- #define sign(x) ((x) < 0 ? -1 : ((x) > 0 ? 1 : 0))
- /* this assumes b > 0 */
- #define modulus(a, b, d) if (((d) = (a) % (b)) < 0) (d) += (b)
---
-2.0.5
-
diff --git a/media-libs/nas/nas-1.9.4-r2.ebuild b/media-libs/nas/nas-1.9.4-r2.ebuild
deleted file mode 100644
index de678c811d99..000000000000
--- a/media-libs/nas/nas-1.9.4-r2.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit multilib-minimal toolchain-funcs
-
-DESCRIPTION="Network Audio System"
-HOMEPAGE="https://radscan.com/nas.html"
-SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
-
-LICENSE="HPND MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="doc static-libs"
-
-RDEPEND="
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- >=x11-libs/libXau-1.0.7-r1[${MULTILIB_USEDEP}]
- x11-libs/libXaw
- x11-libs/libXext
- x11-libs/libXmu
- x11-libs/libXpm
- >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="
- app-text/rman
- sys-devel/bison
- sys-devel/flex
- x11-base/xorg-proto
- x11-misc/gccmakedep
- riscv? ( >=x11-misc/xorg-cf-files-1.0.7-r1 )
- >=x11-misc/imake-1.0.8-r1"
-
-DOCS=( BUILDNOTES FAQ HISTORY README RELEASE TODO )
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.9.2-asneeded.patch"
- "${FILESDIR}/${P}-remove-abs-fabs.patch"
- "${FILESDIR}/${P}-libfl.patch"
- "${FILESDIR}/${P}-fno-config.patch"
-)
-
-src_prepare() {
- default
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- # Need to run econf so that config.guess is updated
- pushd config || die
- econf
- popd || die
- CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
-}
-
-multilib_src_compile() {
- # EXTRA_LDOPTIONS, SHLIBGLOBALSFLAGS #336564#c2
- local emakeopts=(
- AR="$(tc-getAR) cq"
- AS="$(tc-getAS)"
- CC="$(tc-getCC)"
- CDEBUGFLAGS="${CFLAGS}"
- CXX="$(tc-getCXX)"
- CXXDEBUFLAGS="${CXXFLAGS}"
- EXTRA_LDOPTIONS="${LDFLAGS}"
- LD="$(tc-getLD)"
- MAKE="${MAKE:-gmake}"
- RANLIB="$(tc-getRANLIB)"
- SHLIBGLOBALSFLAGS="${LDFLAGS}"
- WORLDOPTS=
- )
-
- if multilib_is_native_abi ; then
- # dumb fix for parallel make issue wrt #446598, Imake sux
- emake "${emakeopts[@]}" -C server/dia all
- emake "${emakeopts[@]}" -C server/dda/voxware all
- emake "${emakeopts[@]}" -C server/os all
- else
- sed -i \
- -e 's/SUBDIRS =.*/SUBDIRS = include lib config/' \
- Makefile || die
- fi
-
- emake "${emakeopts[@]}"
-}
-
-multilib_src_install() {
- # ranlib is used at install phase too wrt #446600
- emake RANLIB="$(tc-getRANLIB)" \
- DESTDIR="${D}" USRLIBDIR=/usr/$(get_libdir) \
- install install.man
-}
-
-multilib_src_install_all() {
- einstalldocs
- if use doc; then
- docinto doc
- dodoc doc/{actions,protocol.txt,README}
- docinto pdf
- dodoc doc/pdf/*.pdf
- fi
-
- mv -vf "${D}"/etc/nas/nasd.conf{.eg,} || die
-
- newconfd "${FILESDIR}"/nas.conf.d nas
- newinitd "${FILESDIR}"/nas.init.d nas
-
- if ! use static-libs; then
- rm -f "${D}"/usr/lib*/libaudio.a || die
- fi
-}