summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/qhull/files/qhull-2010.1-cmake-install.patch98
-rw-r--r--media-libs/qhull/files/qhull-2010.1-overflows.patch50
-rw-r--r--media-libs/qhull/files/qhull-3.1-makefile.patch74
3 files changed, 0 insertions, 222 deletions
diff --git a/media-libs/qhull/files/qhull-2010.1-cmake-install.patch b/media-libs/qhull/files/qhull-2010.1-cmake-install.patch
deleted file mode 100644
index 9e1914d13d29..000000000000
--- a/media-libs/qhull/files/qhull-2010.1-cmake-install.patch
+++ /dev/null
@@ -1,98 +0,0 @@
-diff -Nur qhull-2010.1.orig/CMakeLists.txt qhull-2010.1/CMakeLists.txt
---- qhull-2010.1.orig/CMakeLists.txt 2010-10-03 23:04:04.000000000 +0100
-+++ qhull-2010.1/CMakeLists.txt 2010-10-03 23:26:54.000000000 +0100
-@@ -1,8 +1,44 @@
- project(qhull)
--cmake_minimum_required(VERSION 2.4)
--if(COMMAND cmake_policy)
-- cmake_policy(SET CMP0003 NEW)
--endif(COMMAND cmake_policy)
-+cmake_minimum_required(VERSION 2.6)
-+
-+
-+set(QHULL_VERSION "2010.1")
-+
-+if(INCLUDE_INSTALL_DIR)
-+else()
-+set(INCLUDE_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/include)
-+endif()
-+if(LIB_INSTALL_DIR)
-+else()
-+set(LIB_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/lib)
-+endif()
-+if(BIN_INSTALL_DIR)
-+else()
-+set(BIN_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/bin)
-+endif()
-+if(DOC_INSTALL_DIR)
-+else()
-+set(DOC_INSTALL_DIR ${CMAKE_INSTALL_PREFIX}/share/doc/qhull)
-+endif()
-+
-+message(STATUS)
-+message(STATUS "========== qhull Build Information ==========")
-+message(STATUS "Build Version: ${QHULL_VERSION}")
-+message(STATUS "Install Prefix (CMAKE_INSTALL_PREFIX): ${CMAKE_INSTALL_PREFIX}")
-+message(STATUS "Binary Directory (BIN_INSTALL_DIR): ${BIN_INSTALL_DIR}")
-+message(STATUS "Library Directory (LIB_INSTALL_DIR): ${LIB_INSTALL_DIR}")
-+message(STATUS "Include Directory (INCLUDE_INSTALL_DIR): ${INCLUDE_INSTALL_DIR}")
-+message(STATUS "Documentation Directory (DOC_INSTALL_DIR): ${DOC_INSTALL_DIR}")
-+message(STATUS)
-+message(STATUS "To change any of these options, override them using -D{OPTION_NAME} on the commandline.")
-+message(STATUS "To build and install qhull, run \"make\" and \"make install\"")
-+message(STATUS)
-+
-
- add_subdirectory(src)
-+option(WITH_STATIC_LIBS "Build with a static library" OFF)
-+option(WITH_DOCS "Install HTML documentation" OFF)
-
-+if (WITH_DOCS)
-+install(DIRECTORY html/ DESTINATION ${DOC_INSTALL_DIR})
-+endif (WITH_DOCS)
-diff -Nur qhull-2010.1.orig/src/CMakeLists.txt qhull-2010.1/src/CMakeLists.txt
---- qhull-2010.1.orig/src/CMakeLists.txt 2010-10-03 23:04:04.000000000 +0100
-+++ qhull-2010.1/src/CMakeLists.txt 2010-10-04 00:23:47.000000000 +0100
-@@ -23,8 +23,25 @@
-
- file(GLOB qhull_hdr *.h)
-
--add_library(qhull ${qhull_src})
-+add_library(qhull SHARED ${qhull_src})
- target_link_libraries(qhull m)
-+if(UNIX)
-+ if(APPLE)
-+ set_target_properties(qhull PROPERTIES
-+ INSTALL_NAME_DIR "${LIB_INSTALL_DIR}")
-+ else(APPLE)
-+ set_target_properties(qhull PROPERTIES
-+ INSTALL_RPATH "${LIB_INSTALL_DIR}"
-+ INSTALL_RPATH_USE_LINK_PATH TRUE
-+ BUILD_WITH_INSTALL_RPATH FALSE)
-+ endif(APPLE)
-+endif(UNIX)
-+
-+if(WITH_STATIC_LIBS)
-+ add_library(qhullstatic STATIC ${qhull_src})
-+ set_property(TARGET qhullstatic PROPERTY OUTPUT_NAME "qhull")
-+ install(TARGETS qhullstatic ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
-+endif(WITH_STATIC_LIBS)
-
- set(qhullcmd_SOURCES unix.c)
- set(rbox_SOURCES rbox.c)
-@@ -36,6 +53,7 @@
-
- add_executable(qhullcmd ${qhullcmd_SOURCES})
- target_link_libraries(qhullcmd qhull)
-+set_property(TARGET qhullcmd PROPERTY OUTPUT_NAME "qhull")
-
- add_executable(rbox ${rbox_SOURCES})
- target_link_libraries(rbox qhull)
-@@ -52,3 +70,7 @@
- add_executable(qhalf ${qhalf_SOURCES})
- target_link_libraries(qhalf qhull)
-
-+install(TARGETS qhull qhullcmd rbox qconvex qdelaunay qvoronoi qhalf
-+ RUNTIME DESTINATION ${BIN_INSTALL_DIR}
-+ LIBRARY DESTINATION ${LIB_INSTALL_DIR})
-+install(FILES ${qhull_hdr} DESTINATION ${INCLUDE_INSTALL_DIR}/qhull)
diff --git a/media-libs/qhull/files/qhull-2010.1-overflows.patch b/media-libs/qhull/files/qhull-2010.1-overflows.patch
deleted file mode 100644
index df4aa3da19c7..000000000000
--- a/media-libs/qhull/files/qhull-2010.1-overflows.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 176c01851026125f574a8223ad49ec58b2b58ec0 Mon Sep 17 00:00:00 2001
-From: Johannes Obermayr <johannesobermayr@gmx.de>
-Date: Fri, 23 Jul 2010 20:02:19 +0200
-Subject: [PATCH] Fix some serious compiler warnings causing build breakage on openSUSE.
-
----
- src/global.c | 2 +-
- src/rboxlib.c | 6 +++---
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/global.c b/src/global.c
-index 3c6141a..4c9f56c 100644
---- a/src/global.c
-+++ b/src/global.c
-@@ -614,7 +614,7 @@ void qh_initflags(char *command) {
- if (command <= &qh qhull_command[0] || command > &qh qhull_command[0] + sizeof(qh qhull_command)) {
- if (command != &qh qhull_command[0]) {
- *qh qhull_command= '\0';
-- strncat( qh qhull_command, command, sizeof( qh qhull_command));
-+ strncat(qh qhull_command, command, sizeof(qh qhull_command)-strlen(qh qhull_command)-1);
- }
- while (*s && !isspace(*s)) /* skip program name */
- s++;
-diff --git a/src/rboxlib.c b/src/rboxlib.c
-index 4f11d22..17d01ac 100644
---- a/src/rboxlib.c
-+++ b/src/rboxlib.c
-@@ -124,7 +124,7 @@ int qh_rboxpoints(FILE* fout, FILE* ferr, char* rbox_command) {
- }
-
- *command= '\0';
-- strncat(command, rbox_command, sizeof(command));
-+ strncat(command, rbox_command, sizeof(command)-strlen(command)-1);
-
- while (*s && !isspace(*s)) /* skip program name */
- s++;
-@@ -346,8 +346,8 @@ int qh_rboxpoints(FILE* fout, FILE* ferr, char* rbox_command) {
- }
- }else if (israndom) {
- seed= (int)time(&timedata);
-- sprintf(seedbuf, " t%d", seed); /* appends an extra t, not worth removing */
-- strncat(command, seedbuf, sizeof(command));
-+ printf(seedbuf, " t%d", seed); /* appends an extra t, not worth removing */
-+ strncat(command, seedbuf, sizeof(command)-strlen(command)-1);
- t= strstr(command, " t ");
- if (t)
- strcpy(t+1, t+3); /* remove " t " */
---
-1.6.1
-
diff --git a/media-libs/qhull/files/qhull-3.1-makefile.patch b/media-libs/qhull/files/qhull-3.1-makefile.patch
deleted file mode 100644
index edb6e1766e4c..000000000000
--- a/media-libs/qhull/files/qhull-3.1-makefile.patch
+++ /dev/null
@@ -1,74 +0,0 @@
---- Makefile.old 2001-02-11 21:26:08.000000000 -0500
-+++ Makefile 2007-11-18 08:03:19.000000000 -0500
-@@ -62,7 +62,7 @@
-
- # OBJS in execution frequency order. CFILES after qhull.c are alphabetical
- OBJS = user.o global.o stat.o io.o geom2.o poly2.o \
-- merge.o qhull.o geom.o poly.o qset.o mem.o
-+ merge.o qhull.o geom.o poly.o qset.o mem.o unix.o
-
- CFILES= unix.c qhull.c geom.c geom2.c global.c io.c mem.c merge.c poly.c \
- poly2.c qset.c stat.c user.c qconvex.c qdelaun.c qhalf.c qvoronoi.c
-@@ -78,7 +78,7 @@
- qh-poly.htm qh-qhull.htm qh-set.htm qh-stat.htm qh-user.htm \
- qdelau_f.htm qhalf.htm qvoronoi.htm qvoron_f.htm rbox.htm
-
--all: rbox qconvex qdelaunay qhalf qvoronoi qhull
-+all: rbox qconvex qdelaunay qhalf qvoronoi qhull libqhull.so
-
- unix.o: qhull.h user.h mem.h
- qconvex.o: qhull.h user.h mem.h
-@@ -100,6 +100,8 @@
-
- .c.o:
- $(CC) -c $(CCOPTS1) $<
-+ mkdir -p .libs
-+ $(CC) -c $(CCOPTS1) -fPIC $< -o .libs/$@
-
- clean:
- rm -f *.o ../core qconvex qdelaunay qhalf qvoronoi qhull
-@@ -142,23 +144,23 @@
-
- # don't use ../qconvex. Does not work on Red Hat Linux
- qconvex: qconvex.o libqhull.a
-- $(CC) -o qconvex $(CCOPTS2) qconvex.o -L. -lqhull -lm
-+ $(CC) -o qconvex $(CCOPTS2) qconvex.o -L. libqhull.a -lm
- cp qconvex ..
-
- qdelaunay: qdelaun.o libqhull.a
-- $(CC) -o qdelaunay $(CCOPTS2) qdelaun.o -L. -lqhull -lm
-+ $(CC) -o qdelaunay $(CCOPTS2) qdelaun.o -L. libqhull.a -lm
- cp qdelaunay ..
-
- qhalf: qhalf.o libqhull.a
-- $(CC) -o qhalf $(CCOPTS2) qhalf.o -L. -lqhull -lm
-+ $(CC) -o qhalf $(CCOPTS2) qhalf.o -L. libqhull.a -lm
- cp qhalf ..
-
- qvoronoi: qvoronoi.o libqhull.a
-- $(CC) -o qvoronoi $(CCOPTS2) qvoronoi.o -L. -lqhull -lm
-+ $(CC) -o qvoronoi $(CCOPTS2) qvoronoi.o -L. libqhull.a -lm
- cp qvoronoi ..
-
- qhull: unix.o libqhull.a
-- $(CC) -o qhull $(CCOPTS2) unix.o -L. -lqhull -lm
-+ $(CC) -o qhull $(CCOPTS2) unix.o -L. libqhull.a -lm
- cp qhull ..
- -chmod +x ../eg/q_test ../eg/q_eg ../eg/q_egtest
- -cd ..; ./rbox D4 | ./qhull
-@@ -179,11 +181,13 @@
- cp rbox ..
-
- user_eg: user_eg.o libqhull.a
-- $(CC) -o user_eg $(CCOPTS2) user_eg.o -L. -lqhull -lm
-+ $(CC) -o user_eg $(CCOPTS2) user_eg.o -L. libqhull.a -lm
- cp user_eg ..
-
- user_eg2: user_eg2.o libqhull.a
-- $(CC) -o user_eg2 $(CCOPTS2) user_eg2.o -L. -lqhull -lm
-+ $(CC) -o user_eg2 $(CCOPTS2) user_eg2.o -L. libqhull.a -lm
- cp user_eg2 ..
-
- # end of Makefile
-+libqhull.so: $(OBJS)
-+ c++ -shared -Xlinker -soname -Xlinker $@ -o libqhull.so $(addprefix .libs/,$(OBJS))