summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch')
-rw-r--r--media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch b/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch
new file mode 100644
index 000000000000..8f6fda0ba1b2
--- /dev/null
+++ b/media-plugins/audacious-plugins/files/audacious-plugins-3.2.2-fix-build-sdl.patch
@@ -0,0 +1,19 @@
+commit b6df18997dabe37f4357d977d2dfae07899be5e7
+Author: MichaƂ Lipski <tallica@o2.pl>
+Date: Mon May 7 12:48:23 2012 +0200
+
+ Use pkg-config for libsdl detection. (Gentoo #414999)
+
+diff --git a/configure.ac b/configure.ac
+index 358f841..cbba0ce 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -693,7 +693,7 @@ AC_ARG_ENABLE(sdlout,
+ [enable_sdlout=$enableval], [enable_sdlout=yes])
+
+ if test $enable_sdlout = yes ; then
+- AM_PATH_SDL(1.2.5, [enable_sdlout=yes], [enable_sdlout=no])
++ PKG_CHECK_MODULES([SDL], [sdl >= 1.2.11], [enable_sdlout=yes], [enable_sdlout=no])
+ fi
+
+ if test $enable_sdlout = yes ; then