summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/gst-plugins-hls/gst-plugins-hls-1.20.3.ebuild')
-rw-r--r--media-plugins/gst-plugins-hls/gst-plugins-hls-1.20.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/media-plugins/gst-plugins-hls/gst-plugins-hls-1.20.3.ebuild b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.20.3.ebuild
new file mode 100644
index 000000000000..637be85238d5
--- /dev/null
+++ b/media-plugins/gst-plugins-hls/gst-plugins-hls-1.20.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GST_ORG_MODULE=gst-plugins-bad
+
+inherit gstreamer-meson
+
+DESCRIPTION="HTTP live streaming plugin for GStreamer"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/nettle:0=[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/gst-plugins-bad-1.18.4-use-system-libs-hls.patch
+)
+
+src_prepare() {
+ default
+ gstreamer_system_library gstadaptivedemux_dep:gstadaptivedemux
+ gstreamer_system_package pbutils_dep:gstreamer-pbutils
+ gstreamer_system_package tag_dep:gstreamer-tag
+ gstreamer_system_package video_dep:gstreamer-video
+ gstreamer_system_library gsturidownloader_dep:gsturidownloader
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dhls-crypto=nettle
+ )
+
+ gstreamer_multilib_src_configure
+}