summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/live')
-rw-r--r--media-plugins/live/Manifest2
-rw-r--r--media-plugins/live/live-2017.04.10.ebuild128
-rw-r--r--media-plugins/live/live-2017.04.26.ebuild128
3 files changed, 0 insertions, 258 deletions
diff --git a/media-plugins/live/Manifest b/media-plugins/live/Manifest
index 1ec9ba935713..dafcebe14079 100644
--- a/media-plugins/live/Manifest
+++ b/media-plugins/live/Manifest
@@ -1,4 +1,2 @@
DIST live.2017.01.26.tar.gz 629183 SHA256 3c4d440b79e415eb3a86d30d0cd061d3edcaaa0281909e8629e9756c2c375458 SHA512 2123d78c18cb2a0f522450aa426beceefe7f70b659ec9c9f04045cbde8e53a927b7909172a42da3967be73989b16f444f02e0b70dab671d4c75e567d8939ad23 WHIRLPOOL 49db6d3f25e310dc8d90e7e257af1b5a844bd1efbe79525bb196e7bc4b5d65a56eecac9cb2a421c3425f3a5caae4efa3856469880f1d578117f52e43f67ede48
-DIST live.2017.04.10.tar.gz 629185 SHA256 4c37d9c828f9028403997272e49968c260385dbbaef62e28ba24faef0dda868b SHA512 ab5e790c654b01893fc5409ec69007096b31b19ccecb323319f759738e264f3cde06c7d60b84a4d078fbd20e44aa832352fec61d7ba6e0abbc24027203613349 WHIRLPOOL 2a08d77630f3bec9b639aaa7bf1646bf00ef28152aa21ae0e9092c7d231bb48f7ab751689d7279ca3d11759ef421f1d43c5c5578de6c446a283ab7c587301f62
-DIST live.2017.04.26.tar.gz 629195 SHA256 a97372c84d49520dbaa595b65c39800fbd7813e717b5df9cd6c70308ce1a6033 SHA512 444b3c63e30b2ddd0fac8b11f09efff3796953f6bad558cc59c093273a351ef6b1631abc5d89a8be422caf54b1c46104c59b507fc104785795c3e8622a8a4efd WHIRLPOOL cbf7cf011fb49b4ad0c24d87e4fcda220354330ac52778c233789b1c836047e33424cbdfea3ab7d8e06ef6124148c4313218f2d3e98c2d0193a33285eacda6b9
DIST live.2017.05.24.tar.gz 629181 SHA256 3512575c13cd52760bdfb14c8a15ab882ad45efa12a919fb70302185872446e5 SHA512 d00d87d4e011f1c100331e517f2939fe85e25d0920b9418d66c4f9254b2441c569ef7c3ece05123132f3dc44da595a62f57f0840ca33e40c48c2b193bc44b01b WHIRLPOOL 9a3d595655fe9488391431bb022dadbe2b3085b9280a506494e05c7ba0e9cf08c54a95f4942260b6d081836af13ffa85458f20ca697b865595b66e8c9d409983
diff --git a/media-plugins/live/live-2017.04.10.ebuild b/media-plugins/live/live-2017.04.10.ebuild
deleted file mode 100644
index 22ccb8b6eb6d..000000000000
--- a/media-plugins/live/live-2017.04.10.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit flag-o-matic eutils toolchain-funcs multilib multilib-minimal
-
-DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz
- mirror://gentoo/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="examples static-libs"
-DOCS=( "live-shared/README" )
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=7
-SLOT="0/${LIVE_ABI_VERSION}"
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${S}"
- mv "${WORKDIR}/live" "${S}/" || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-recursive3.patch"
-
- if use static-libs ; then
- cp -pPR live live-shared
- mv live live-static
- else
- mv live live-shared
- fi
-
- use static-libs && cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so-r1" live-shared
-
- case ${CHOST} in
- *-solaris*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-static/config.gentoo \
- || die ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-shared/config.gentoo-so-r1 \
- || die
- ;;
- *-darwin*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/$/ /' \
- -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
- live-static/config.gentoo \
- || die static ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
- -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
- -e '/^LIB_SUFFIX /s/so/dylib/' \
- live-shared/config.gentoo-so-r1 \
- || die shared
- ;;
- esac
- multilib_copy_sources
-}
-
-src_configure() { :; }
-
-multilib_src_compile() {
- tc-export CC CXX LD
-
- if use static-libs ; then
- cd "${BUILD_DIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
- fi
-
- cd "${BUILD_DIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so-r1
- local suffix=$(get_libname ${LIVE_ABI_VERSION})
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
-
- for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
- pushd "${BUILD_DIR}/live-shared/${i}" > /dev/null
- ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
- popd > /dev/null
- done
-
- if multilib_is_native_abi; then
- einfo "Beginning programs build"
- for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
- cd "${BUILD_DIR}/live-shared/${i}"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- done
- fi
-}
-
-multilib_src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- use static-libs && dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
- dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- if multilib_is_native_abi; then
- # Should we really install these?
- use examples && find live-shared/testProgs -type f -perm 755 -print0 | \
- xargs -0 dobin
-
- dobin live-shared/mediaServer/live555MediaServer
- dobin live-shared/proxyServer/live555ProxyServer
- fi
-}
diff --git a/media-plugins/live/live-2017.04.26.ebuild b/media-plugins/live/live-2017.04.26.ebuild
deleted file mode 100644
index 22ccb8b6eb6d..000000000000
--- a/media-plugins/live/live-2017.04.26.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit flag-o-matic eutils toolchain-funcs multilib multilib-minimal
-
-DESCRIPTION="Libraries for standards-based RTP/RTCP/RTSP multimedia streaming"
-HOMEPAGE="http://www.live555.com/"
-SRC_URI="http://www.live555.com/liveMedia/public/${P/-/.}.tar.gz
- mirror://gentoo/${P/-/.}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="examples static-libs"
-DOCS=( "live-shared/README" )
-
-# Alexis Ballier <aballier@gentoo.org>
-# Be careful, bump this everytime you bump the package and the ABI has changed.
-# If you don't know, ask someone.
-LIVE_ABI_VERSION=7
-SLOT="0/${LIVE_ABI_VERSION}"
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${S}"
- mv "${WORKDIR}/live" "${S}/" || die
-}
-
-src_prepare() {
- epatch "${FILESDIR}/${PN}-recursive3.patch"
-
- if use static-libs ; then
- cp -pPR live live-shared
- mv live live-static
- else
- mv live live-shared
- fi
-
- use static-libs && cp "${FILESDIR}/config.gentoo" live-static
- cp "${FILESDIR}/config.gentoo-so-r1" live-shared
-
- case ${CHOST} in
- *-solaris*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-static/config.gentoo \
- || die ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DSOLARIS -DXLOCALE_NOT_USED/' \
- -e '/^LIBS_FOR_CONSOLE_APPLICATION /s/$/ -lsocket -lnsl/' \
- live-shared/config.gentoo-so-r1 \
- || die
- ;;
- *-darwin*)
- use static-libs && { sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/$/ /' \
- -e '/^LIBRARY_LINK_OPTS /s/-Bstatic//' \
- live-static/config.gentoo \
- || die static ; }
- sed -i \
- -e '/^COMPILE_OPTS /s/$/ -DBSD=1 -DHAVE_SOCKADDR_LEN=1/' \
- -e '/^LINK /s/$/ /' \
- -e '/^LIBRARY_LINK /s/=.*$/= $(CXX) -o /' \
- -e '/^LIBRARY_LINK_OPTS /s:-shared.*$:-undefined suppress -flat_namespace -dynamiclib -install_name '"${EPREFIX}/usr/$(get_libdir)/"'$@:' \
- -e '/^LIB_SUFFIX /s/so/dylib/' \
- live-shared/config.gentoo-so-r1 \
- || die shared
- ;;
- esac
- multilib_copy_sources
-}
-
-src_configure() { :; }
-
-multilib_src_compile() {
- tc-export CC CXX LD
-
- if use static-libs ; then
- cd "${BUILD_DIR}/live-static"
-
- einfo "Beginning static library build"
- ./genMakefiles gentoo
- emake -j1 LINK_OPTS="-L. $(raw-ldflags)" || die "failed to build static libraries"
- fi
-
- cd "${BUILD_DIR}/live-shared"
- einfo "Beginning shared library build"
- ./genMakefiles gentoo-so-r1
- local suffix=$(get_libname ${LIVE_ABI_VERSION})
- emake -j1 LINK_OPTS="-L. ${LDFLAGS}" LIB_SUFFIX="${suffix#.}" || die "failed to build shared libraries"
-
- for i in liveMedia groupsock UsageEnvironment BasicUsageEnvironment ; do
- pushd "${BUILD_DIR}/live-shared/${i}" > /dev/null
- ln -s lib${i}.${suffix#.} lib${i}$(get_libname) || die
- popd > /dev/null
- done
-
- if multilib_is_native_abi; then
- einfo "Beginning programs build"
- for i in $(use examples && echo "testProgs") proxyServer mediaServer ; do
- cd "${BUILD_DIR}/live-shared/${i}"
- emake LINK_OPTS="-L. ${LDFLAGS}" || die "failed to build test programs"
- done
- fi
-}
-
-multilib_src_install() {
- for library in UsageEnvironment liveMedia BasicUsageEnvironment groupsock; do
- use static-libs && dolib.a live-static/${library}/lib${library}.a
- dolib.so live-shared/${library}/lib${library}$(get_libname ${LIVE_ABI_VERSION})
- dosym lib${library}$(get_libname ${LIVE_ABI_VERSION}) /usr/$(get_libdir)/lib${library}$(get_libname)
-
- insinto /usr/include/${library}
- doins live-shared/${library}/include/*h
- done
-
- if multilib_is_native_abi; then
- # Should we really install these?
- use examples && find live-shared/testProgs -type f -perm 755 -print0 | \
- xargs -0 dobin
-
- dobin live-shared/mediaServer/live555MediaServer
- dobin live-shared/proxyServer/live555ProxyServer
- fi
-}