summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-radio/tlf/tlf-1.4.0.ebuild')
-rw-r--r--media-radio/tlf/tlf-1.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-radio/tlf/tlf-1.4.0.ebuild b/media-radio/tlf/tlf-1.4.0.ebuild
new file mode 100644
index 000000000000..c90d371f9458
--- /dev/null
+++ b/media-radio/tlf/tlf-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic
+
+DESCRIPTION="Console-mode amateur radio contest logger"
+HOMEPAGE="http://home.iae.nl/users/reinc/TLF-0.2.html"
+SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="sys-libs/ncurses:=
+ dev-libs/glib:2
+ media-libs/hamlib
+ media-sound/sox
+ dev-libs/xmlrpc-c[curl]"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )"
+
+src_configure() {
+ append-ldflags -L/usr/$(get_libdir)/hamlib
+ econf --docdir=/usr/share/doc/${PF} --enable-fldigi-xmlrpc
+}