summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/asunder/asunder-2.9.3-r1.ebuild')
-rw-r--r--media-sound/asunder/asunder-2.9.3-r1.ebuild26
1 files changed, 9 insertions, 17 deletions
diff --git a/media-sound/asunder/asunder-2.9.3-r1.ebuild b/media-sound/asunder/asunder-2.9.3-r1.ebuild
index 59b9fd215d8f..df537f03bf42 100644
--- a/media-sound/asunder/asunder-2.9.3-r1.ebuild
+++ b/media-sound/asunder/asunder-2.9.3-r1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit xdg-utils
+inherit xdg
-DESCRIPTION="A graphical Audio CD ripper and encoder with support for many output formats"
+DESCRIPTION="Graphical Audio CD ripper and encoder with support for many output formats"
HOMEPAGE="http://littlesvr.ca/asunder/"
SRC_URI="http://littlesvr.ca/${PN}/releases/${P}.tar.bz2"
@@ -14,14 +14,14 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="flac mac mp3 musepack opus vorbis wavpack"
-COMMON_DEPEND=">=media-libs/libcddb-0.9.5
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND=">=media-libs/libcddb-0.9.5
media-sound/cdparanoia
x11-libs/gtk+:2"
-DEPEND="${COMMON_DEPEND}
- dev-util/intltool
- virtual/pkgconfig
- sys-devel/gettext"
-RDEPEND="${COMMON_DEPEND}
+RDEPEND="${DEPEND}
flac? ( media-libs/flac )
mac? ( media-sound/mac )
mp3? ( media-sound/lame )
@@ -34,11 +34,3 @@ src_prepare() {
default
sed -i -e 's:cd syslogng && $(MAKE) install:true:' Makefile.in || die
}
-
-pkg_postinst() {
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}