summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/aucatctl/aucatctl-0.1.ebuild')
-rw-r--r--media-sound/aucatctl/aucatctl-0.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/media-sound/aucatctl/aucatctl-0.1.ebuild b/media-sound/aucatctl/aucatctl-0.1.ebuild
index 1357fbb643e4..a04a482f9d15 100644
--- a/media-sound/aucatctl/aucatctl-0.1.ebuild
+++ b/media-sound/aucatctl/aucatctl-0.1.ebuild
@@ -1,11 +1,14 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="A tool for controlling aucat and/or sndiod volume through MIDI"
HOMEPAGE="http://www.sndio.org/"
SRC_URI="http://www.sndio.org/${P}.tar.gz"
+
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64"
@@ -25,3 +28,8 @@ src_prepare() {
-e 's?LDADD = -lsndio?LDADD = -lbsd -lsndio?' \
Makefile || die "Failed modifying Makefile"
}
+
+src_compile() {
+ tc-export CC
+ default
+}