summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/deadbeef-mpris2-plugin/deadbeef-mpris2-plugin-1.16.ebuild')
-rw-r--r--media-sound/deadbeef-mpris2-plugin/deadbeef-mpris2-plugin-1.16.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-sound/deadbeef-mpris2-plugin/deadbeef-mpris2-plugin-1.16.ebuild b/media-sound/deadbeef-mpris2-plugin/deadbeef-mpris2-plugin-1.16.ebuild
new file mode 100644
index 000000000000..2dd504ba3517
--- /dev/null
+++ b/media-sound/deadbeef-mpris2-plugin/deadbeef-mpris2-plugin-1.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="MPRISv2 plugin for the DeaDBeeF music player"
+HOMEPAGE="https://github.com/DeaDBeeF-Player/deadbeef-mpris2-plugin"
+SRC_URI="https://github.com/DeaDBeeF-Player/deadbeef-mpris2-plugin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="debug"
+
+DEPEND="
+ dev-libs/glib:2
+ >=media-sound/deadbeef-1.8.0[cover]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ # Remove static library
+ rm "${ED}"/usr/$(get_libdir)/deadbeef/mpris.la || die
+
+}