summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild')
-rw-r--r--media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild b/media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild
new file mode 100644
index 000000000000..7c768db2d435
--- /dev/null
+++ b/media-sound/fluid-soundfont/fluid-soundfont-3.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="The Fluid R3 soundfont"
+HOMEPAGE="http://musescore.org/en/handbook/soundfont"
+SRC_URI="http://prereleases.musescore.org/soundfont/${PN}_${PV}.tar.gz
+ timidity? ( http://dev.gentoo.org/~hwoarang/distfiles/timidity.cfg.bz2 )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="timidity"
+
+RDEPEND="timidity? ( app-eselect/eselect-timidity )"
+
+src_install() {
+ insinto /usr/share/sounds/sf2
+ doins FluidR3_GM.sf2 FluidR3_GS.sf2
+
+ dodoc README
+
+ if use timidity; then
+ insinto /usr/share/timidity/${PN}
+ doins "${WORKDIR}"/timidity.cfg
+ fi
+}