summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild')
-rw-r--r--media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild30
1 files changed, 11 insertions, 19 deletions
diff --git a/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild b/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
index 3ac52e635b65..d83ca18de9f9 100644
--- a/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
+++ b/media-sound/gmusicbrowser/gmusicbrowser-9999.ebuild
@@ -13,7 +13,7 @@ EGIT_REPO_URI="git://github.com/squentin/${PN}.git"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="doc"
+IUSE="dbus doc extras gstreamer libnotify mplayer"
GSTREAMER_DEPEND="
dev-perl/GStreamer
@@ -31,12 +31,12 @@ RDEPEND="dev-lang/perl
dev-perl/gtk2-perl
virtual/perl-MIME-Base64
|| ( net-misc/wget dev-perl/AnyEvent-HTTP )
- || (
- ( ${GSTREAMER_DEPEND} )
- ( ${MPLAYER_DEPEND} )
- ( ${MPV_DEPEND} )
- ( ${OTHER_DEPEND} )
- )"
+ dbus? ( dev-perl/Net-DBus )
+ gstreamer? ( ${GSTREAMER_DEPEND} )
+ mplayer? ( || ( ${MPLAYER_DEPEND} ${MPV_DEPEND} ) )
+ !gstreamer? ( !mplayer? ( ${OTHER_DEPEND} ) )
+ extras? ( dev-perl/gnome2-wnck )
+ libnotify? ( dev-perl/Gtk2-Notify )"
DEPEND="sys-devel/gettext
doc? ( dev-perl/Text-Markdown )"
@@ -64,18 +64,10 @@ pkg_postinst() {
elog "Gmusicbrowser supports gstreamer, mplayer, mpv and mpg123/ogg123..."
elog "for audio playback. Needed dependencies:"
- elog "Gstreamer: ${GSTREAMER_DEPEND}"
- elog "mplayer: ${MPLAYER_DEPEND}"
- elog "mpv: ${MPV_DEPEND}"
- elog "mpg123/ogg123...: ${OTHER_DEPEND}"
- elog
- elog "This ebuild just ensures at least one implementation is installed!"
- elog
- elog "other optional dependencies:"
- elog " dev-perl/Net-DBus (for dbus support and mpris1/2 plugins)"
- elog " dev-perl/Gtk2-WebKit (for Web context plugin)"
- elog " dev-perl/Gtk2-Notify (for Notify plugin)"
- elog " dev-perl/gnome2-wnck (for Titlebar plugin)"
+ elog " Gstreamer: ${GSTREAMER_DEPEND}"
+ elog " mplayer: ${MPLAYER_DEPEND}"
+ elog " mpv: ${MPV_DEPEND}"
+ elog " mpg123/ogg123...: ${OTHER_DEPEND}"
}
pkg_postrm() {