summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/imp3sh/imp3sh-0.2.4.ebuild')
-rw-r--r--media-sound/imp3sh/imp3sh-0.2.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-sound/imp3sh/imp3sh-0.2.4.ebuild b/media-sound/imp3sh/imp3sh-0.2.4.ebuild
new file mode 100644
index 000000000000..15d06166d580
--- /dev/null
+++ b/media-sound/imp3sh/imp3sh-0.2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="flexible playlist manipulation shell and song player/streamer"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses
+ media-libs/libvorbis
+ media-libs/libogg
+ media-libs/libao"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf
+ emake CCLD=$(tc-getCXX) || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README* CHANGES web/README.imp3web web/imp3web.php EXAMPLE.imp3sh EXTERNAL.players
+ # Some docs are liner notes in the actual .c files. UHG.
+ dodoc piped-io/imp3sh*.c
+}