summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/musescore/files/musescore-2.0.3-fix-buildsystem.patch')
-rw-r--r--media-sound/musescore/files/musescore-2.0.3-fix-buildsystem.patch479
1 files changed, 479 insertions, 0 deletions
diff --git a/media-sound/musescore/files/musescore-2.0.3-fix-buildsystem.patch b/media-sound/musescore/files/musescore-2.0.3-fix-buildsystem.patch
new file mode 100644
index 000000000000..0fb52db915ca
--- /dev/null
+++ b/media-sound/musescore/files/musescore-2.0.3-fix-buildsystem.patch
@@ -0,0 +1,479 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2c4fe57..b7a5cde 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -147,23 +147,13 @@ if ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
+ endif()
+ endif ("${CMAKE_CXX_COMPILER_ID}" MATCHES "GNU")
+
+-if (APPLE)
+- set(CMAKE_CXX_FLAGS_DEBUG "-std=c++11 -fPIC -stdlib=libc++ -g -Wno-inconsistent-missing-override")
+- set(CMAKE_CXX_FLAGS_RELEASE "-std=c++11 -fPIC -stdlib=libc++ -O2 -DNDEBUG -DQT_NO_DEBUG -Wno-inconsistent-missing-override")
+-else (APPLE)
+- if (MINGW)
+- # -mno-ms-bitfields see #22048
+- set(CMAKE_CXX_FLAGS_DEBUG "-std=c++11 -mno-ms-bitfields -g")
+- set(CMAKE_CXX_FLAGS_RELEASE "-std=c++11 -mno-ms-bitfields -O2 -DNDEBUG -DQT_NO_DEBUG")
+- set(CMAKE_EXE_LINKER_FLAGS "-Wl,--large-address-aware")
+- else (MINGW)
+- set(CMAKE_CXX_FLAGS_DEBUG "-std=c++11 -fPIC -fPIE -g")
+- set(CMAKE_CXX_FLAGS_RELEASE "-std=c++11 -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG")
+- endif (MINGW)
+-endif(APPLE)
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -fPIE -DNDEBUG -DQT_NO_DEBUG")
++set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD_REQUIRED ON)
++set(CMAKE_CXX_EXTENSIONS OFF)
+
+ set(CMAKE_INCLUDE_CURRENT_DIR TRUE)
+-set(CMAKE_BUILD_WITH_INSTALL_RPATH ON) # Call CMake with option -DCMAKE_SKIP_RPATH to not set RPATH (Debian packaging requirement)
++set(CMAKE_BUILD_WITH_INSTALL_RPATH OFF) # Call CMake with option -DCMAKE_SKIP_RPATH to not set RPATH (Debian packaging requirement)
+ set(CMAKE_SKIP_RULE_DEPENDENCY TRUE)
+
+ # The Mscore version number.
+@@ -450,7 +440,6 @@ if (NOT MINGW AND NOT APPLE)
+ # set library search path for runtime linker to load the same
+ # qt libraries as we used at compile time
+ #
+- SET(CMAKE_INSTALL_RPATH "${_qt5Core_install_prefix}/lib") # ignored if CMAKE_SKIP_RPATH="TRUE"
+ string(TOUPPER "mscore${MSCORE_INSTALL_SUFFIX}" MAN_MSCORE_UPPER) # Command name shown in uppercase in man pages by convention
+ if (${MSCORE_INSTALL_SUFFIX} MATCHES "portable") # Note: "-portable-anything" would match
+ # Build portable AppImage as per https://github.com/probonopd/AppImageKit
+@@ -554,11 +543,7 @@ add_custom_command(
+ DEPENDS ${PROJECT_SOURCE_DIR}/all.h
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ )
+-if (MINGW)
+- set(BUILD_PCH false)
+-else (MINGW)
+- set(BUILD_PCH true)
+-endif(MINGW)
++set(BUILD_PCH false)
+
+ precompiled_header(QT_INCLUDES all ${BUILD_PCH})
+
+diff --git a/aeolus/CMakeLists.txt b/aeolus/CMakeLists.txt
+index 7962e87..a23aef3 100644
+--- a/aeolus/CMakeLists.txt
++++ b/aeolus/CMakeLists.txt
+@@ -43,7 +43,7 @@ add_library (aeolus STATIC
+ set_target_properties (
+ aeolus
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ install(DIRECTORY
+diff --git a/audiofile/CMakeLists.txt b/audiofile/CMakeLists.txt
+index 5b1dd48..0d28df8 100644
+--- a/audiofile/CMakeLists.txt
++++ b/audiofile/CMakeLists.txt
+@@ -26,7 +26,7 @@ add_library (audiofile STATIC
+ set_target_properties (
+ audiofile
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(audiofile all)
+diff --git a/awl/CMakeLists.txt b/awl/CMakeLists.txt
+index 9589cce..f4172ed 100644
+--- a/awl/CMakeLists.txt
++++ b/awl/CMakeLists.txt
+@@ -43,7 +43,7 @@ add_library (
+ set_target_properties (
+ awl
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(awl all)
+diff --git a/build/CreatePrecompiledHeader.cmake b/build/CreatePrecompiledHeader.cmake
+index 6cb671a..3d4aae3 100644
+--- a/build/CreatePrecompiledHeader.cmake
++++ b/build/CreatePrecompiledHeader.cmake
+@@ -36,7 +36,7 @@ macro( precompiled_header includes header_name build_pch)
+ set (PCH ${PROJECT_BINARY_DIR}/${header_name}.h.gch)
+ add_custom_command(
+ OUTPUT ${PROJECT_BINARY_DIR}/${header_name}.h.gch
+- COMMAND ${CMAKE_CXX_COMPILER} -x c++-header -g ${compile_flags} -o ${header_name}.h.gch ${header_name}.h
++ COMMAND ${CMAKE_CXX_COMPILER} -x c++-header ${compile_flags} -o ${header_name}.h.gch ${header_name}.h
+ DEPENDS ${PROJECT_BINARY_DIR}/${header_name}.h
+ WORKING_DIRECTORY ${PROJECT_BINARY_DIR}
+ VERBATIM
+diff --git a/bww2mxml/CMakeLists.txt b/bww2mxml/CMakeLists.txt
+index d6b7794..acec8b5 100644
+--- a/bww2mxml/CMakeLists.txt
++++ b/bww2mxml/CMakeLists.txt
+@@ -49,7 +49,7 @@ if (NOT MINGW AND NOT APPLE)
+ set_target_properties (
+ bww2mxml
+ PROPERTIES
+- COMPILE_FLAGS "-x c++ -include ${PROJECT_BINARY_DIR}/all.h -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "-x c++ -include ${PROJECT_BINARY_DIR}/all.h -Wall -Wextra -Winvalid-pch"
+ )
+
+ target_link_libraries(bww2mxml
+diff --git a/effects/CMakeLists.txt b/effects/CMakeLists.txt
+index a695f1d..cf94cae 100644
+--- a/effects/CMakeLists.txt
++++ b/effects/CMakeLists.txt
+@@ -44,7 +44,7 @@ add_library (effects STATIC
+ set_target_properties (
+ effects
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(effects all)
+diff --git a/fluid/CMakeLists.txt b/fluid/CMakeLists.txt
+index 1dc8d2f..3fede66 100644
+--- a/fluid/CMakeLists.txt
++++ b/fluid/CMakeLists.txt
+@@ -45,7 +45,7 @@ add_library (fluid STATIC
+ set_target_properties (
+ fluid
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(fluid all)
+diff --git a/fonttools/CMakeLists.txt b/fonttools/CMakeLists.txt
+index 74a525b..f318f4c 100644
+--- a/fonttools/CMakeLists.txt
++++ b/fonttools/CMakeLists.txt
+@@ -19,5 +19,5 @@ add_executable(
+ )
+
+ target_link_libraries(genft ${QT_LIBRARIES} -lfreetype)
+-set_target_properties(genft PROPERTIES COMPILE_FLAGS "-I/usr/include/freetype2 -g -Wall -Wextra -Winvalid-pch")
++set_target_properties(genft PROPERTIES COMPILE_FLAGS "-I/usr/include/freetype2 -Wall -Wextra -Winvalid-pch")
+
+diff --git a/libmscore/CMakeLists.txt b/libmscore/CMakeLists.txt
+index 446d413..5d871a8 100644
+--- a/libmscore/CMakeLists.txt
++++ b/libmscore/CMakeLists.txt
+@@ -71,8 +71,8 @@ add_library (
+ set_target_properties (
+ libmscore
+ PROPERTIES
+- COMPILE_FLAGS "-g ${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+-# COMPILE_FLAGS "-g ${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch -Woverloaded-virtual"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
++# COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch -Woverloaded-virtual"
+ )
+
+ xcode_pch(libmscore all)
+diff --git a/manual/CMakeLists.txt b/manual/CMakeLists.txt
+index cf6edca..ceffd73 100644
+--- a/manual/CMakeLists.txt
++++ b/manual/CMakeLists.txt
+@@ -36,13 +36,13 @@ if(APPLE)
+ set_target_properties (
+ genManual
+ PROPERTIES
+- COMPILE_FLAGS "-include all.h -D TESTROOT=\\\\\"${PROJECT_SOURCE_DIR}\\\\\" -g -Wall -Wextra"
++ COMPILE_FLAGS "-include all.h -D TESTROOT=\\\\\"${PROJECT_SOURCE_DIR}\\\\\" -Wall -Wextra"
+ )
+ else(APPLE)
+ set_target_properties (
+ genManual
+ PROPERTIES
+- COMPILE_FLAGS "-include all.h -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -g -Wall -Wextra"
++ COMPILE_FLAGS "-include all.h -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -Wall -Wextra"
+ )
+ endif(APPLE)
+
+diff --git a/midi/CMakeLists.txt b/midi/CMakeLists.txt
+index 05fbb83..ea95480 100644
+--- a/midi/CMakeLists.txt
++++ b/midi/CMakeLists.txt
+@@ -27,7 +27,7 @@ add_library (midi STATIC
+ set_target_properties (
+ midi
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(midi all)
+diff --git a/miditools/CMakeLists.txt b/miditools/CMakeLists.txt
+index 6df79c4..f8145e0 100644
+--- a/miditools/CMakeLists.txt
++++ b/miditools/CMakeLists.txt
+@@ -13,7 +13,7 @@
+ add_executable (smf2xml smf2xml.cpp xmlwriter.cpp midifile.cpp)
+
+ set_target_properties(smf2xml
+- PROPERTIES COMPILE_FLAGS "-g -Wall -Wextra"
++ PROPERTIES COMPILE_FLAGS "-Wall -Wextra"
+ )
+ target_link_libraries(smf2xml
+ ${QT_LIBRARIES}
+@@ -23,7 +23,7 @@ add_executable (xml2smf xml2smf.cpp xmlreader.cpp midifile.cpp)
+
+ set_target_properties (
+ xml2smf
+- PROPERTIES COMPILE_FLAGS "-g -Wall -Wextra"
++ PROPERTIES COMPILE_FLAGS "-Wall -Wextra"
+ )
+ target_link_libraries(xml2smf
+ ${QT_LIBRARIES}
+diff --git a/mscore/CMakeLists.txt b/mscore/CMakeLists.txt
+index 3592012..b50e2bc 100644
+--- a/mscore/CMakeLists.txt
++++ b/mscore/CMakeLists.txt
+@@ -370,7 +370,7 @@ if (MINGW)
+ if(CMAKE_BUILD_TYPE MATCHES "DEBUG")
+ set_target_properties( mscore
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch ${QT_DEFINITIONS} -DQT_SVG_LIB -DQT_GUI_LIB -DQT_XML_LIB -DQT_CORE_LIB"
+ LINK_FLAGS "${PROJECT_BINARY_DIR}/resfile.o -mwindows -mconsole -L ${CROSSQT}/lib"
+ )
+ else(CMAKE_BUILD_TYPE MATCHES "DEBUG")
+@@ -493,7 +493,7 @@ else (MINGW)
+ set_target_properties (
+ mscore
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wno-overloaded-virtual -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wno-overloaded-virtual -Winvalid-pch"
+ )
+
+ if (OMR)
+diff --git a/mstyle/CMakeLists.txt b/mstyle/CMakeLists.txt
+index e60d901..d3ba643 100644
+--- a/mstyle/CMakeLists.txt
++++ b/mstyle/CMakeLists.txt
+@@ -49,7 +49,7 @@ add_library (
+ set_target_properties (
+ mstyle
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(mstyle all)
+diff --git a/mtest/CMakeLists.txt b/mtest/CMakeLists.txt
+index 55072b0..cab1a18 100644
+--- a/mtest/CMakeLists.txt
++++ b/mtest/CMakeLists.txt
+@@ -113,20 +113,10 @@ target_link_libraries(
+
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Widgets_EXECUTABLE_COMPILE_FLAGS}")
+
+-if (APPLE)
+- set(CMAKE_CXX_FLAGS_DEBUG "-std=c++0x -fPIC -stdlib=libc++ -g -Wno-inconsistent-missing-override")
+- set(CMAKE_CXX_FLAGS_RELEASE "-std=c++0x -fPIC -stdlib=libc++ -O2 -DNDEBUG -DQT_NO_DEBUG -Wno-inconsistent-missing-override")
+-else (APPLE)
+- if (MINGW)
+- # -mno-ms-bitfields see #22048
+- set(CMAKE_CXX_FLAGS_DEBUG "-std=gnu++0x -mno-ms-bitfields -g")
+- set(CMAKE_CXX_FLAGS_RELEASE "-std=gnu++0x -mno-ms-bitfields -O2 -DNDEBUG -DQT_NO_DEBUG")
+- else (MINGW)
+- set(CMAKE_CXX_FLAGS_DEBUG "-std=gnu++0x -fPIC -fPIE -g")
+- set(CMAKE_CXX_FLAGS_RELEASE "-std=gnu++0x -fPIC -O2 -DNDEBUG -DQT_NO_DEBUG")
+- endif (MINGW)
+-endif(APPLE)
+-
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -fPIE -DNDEBUG -DQT_NO_DEBUG")
++set(CMAKE_CXX_STANDARD 11)
++set(CMAKE_CXX_STANDARD_REQUIRED ON)
++set(CMAKE_CXX_EXTENSIONS OFF)
+
+ string(REPLACE ";" ";-I" INC "${QT_INCLUDES}")
+
+@@ -134,17 +124,17 @@ if (APPLE)
+ set_target_properties (
+ testutils
+ PROPERTIES
+- COMPILE_FLAGS "-include all.h -D TESTROOT=\\\\\"${PROJECT_SOURCE_DIR}\\\\\" -g -Wall -Wextra"
++ COMPILE_FLAGS "-include all.h -D TESTROOT=\\\\\"${PROJECT_SOURCE_DIR}\\\\\" -Wall -Wextra"
+ )
+ else (APPLE)
+ set_target_properties (
+ testutils
+ PROPERTIES
+- COMPILE_FLAGS "-include all.h -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -g -Wall -Wextra"
++ COMPILE_FLAGS "-include all.h -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -Wall -Wextra"
+ )
+ endif(APPLE)
+
+-# COMPILE_FLAGS "-include all.h -I ${INC} -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -g -Wall -Wextra"
++# COMPILE_FLAGS "-include all.h -I ${INC} -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -Wall -Wextra"
+
+ add_custom_target(report
+ COMMAND ant -f ${PROJECT_SOURCE_DIR}/mtest/build.xml -Droot.dir=${PROJECT_BINARY_DIR}/mtest report
+diff --git a/mtest/cmake.inc b/mtest/cmake.inc
+index 0fa9aa8..9ef0177 100644
+--- a/mtest/cmake.inc
++++ b/mtest/cmake.inc
+@@ -57,16 +57,16 @@ set_target_properties (
+ ${TARGET}
+ PROPERTIES
+ AUTOMOC true
+- COMPILE_FLAGS "-include all.h -D QT_GUI_LIB -D TESTROOT=\\\\\"${PROJECT_SOURCE_DIR}\\\\\" -g -Wall -Wextra"
+- LINK_FLAGS "-g -stdlib=libc++"
++ COMPILE_FLAGS "-include all.h -D QT_GUI_LIB -D TESTROOT=\\\\\"${PROJECT_SOURCE_DIR}\\\\\" -Wall -Wextra"
++ LINK_FLAGS "-stdlib=libc++"
+ )
+ else(APPLE)
+ set_target_properties (
+ ${TARGET}
+ PROPERTIES
+ AUTOMOC true
+- COMPILE_FLAGS "-include all.h -D QT_GUI_LIB -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -g -Wall -Wextra"
+- LINK_FLAGS "-g"
++ COMPILE_FLAGS "-include all.h -D QT_GUI_LIB -D TESTROOT=\\\"${PROJECT_SOURCE_DIR}\\\" -Wall -Wextra"
++ LINK_FLAGS ""
+ )
+ endif(APPLE)
+
+diff --git a/omr/CMakeLists.txt b/omr/CMakeLists.txt
+index 88615e5..d719e89 100644
+--- a/omr/CMakeLists.txt
++++ b/omr/CMakeLists.txt
+@@ -42,7 +42,7 @@ add_library (
+ set_target_properties (
+ omr
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(omr all)
+diff --git a/synthesizer/CMakeLists.txt b/synthesizer/CMakeLists.txt
+index 0520920..e9bd15b 100644
+--- a/synthesizer/CMakeLists.txt
++++ b/synthesizer/CMakeLists.txt
+@@ -29,7 +29,7 @@ add_library (synthesizer STATIC
+ set_target_properties (
+ synthesizer
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(synthesizer all)
+diff --git a/thirdparty/beatroot/CMakeLists.txt b/thirdparty/beatroot/CMakeLists.txt
+index ae905c7..9b039e8 100644
+--- a/thirdparty/beatroot/CMakeLists.txt
++++ b/thirdparty/beatroot/CMakeLists.txt
+@@ -14,7 +14,7 @@ add_library (
+
+ set_target_properties( beatroot
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(beatroot all)
+diff --git a/thirdparty/diff/CMakeLists.txt b/thirdparty/diff/CMakeLists.txt
+index d0155b2..35bd6ac 100644
+--- a/thirdparty/diff/CMakeLists.txt
++++ b/thirdparty/diff/CMakeLists.txt
+@@ -36,7 +36,7 @@ add_library(diff_match_patch STATIC
+ set_target_properties (
+ diff_match_patch
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(diff_match_patch all)
+diff --git a/thirdparty/kQOAuth/CMakeLists.txt b/thirdparty/kQOAuth/CMakeLists.txt
+index 9beb6b1..f7ec1c5 100644
+--- a/thirdparty/kQOAuth/CMakeLists.txt
++++ b/thirdparty/kQOAuth/CMakeLists.txt
+@@ -40,7 +40,7 @@ add_library(kqoauth STATIC
+ set_target_properties (
+ kqoauth
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -I ${PROJECT_SOURCE_DIR}/thirdparty/openssl/include -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -I ${PROJECT_SOURCE_DIR}/thirdparty/openssl/include -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(kqoauth all)
+diff --git a/thirdparty/ofqf/CMakeLists.txt b/thirdparty/ofqf/CMakeLists.txt
+index fc39a0a..8c11f07 100644
+--- a/thirdparty/ofqf/CMakeLists.txt
++++ b/thirdparty/ofqf/CMakeLists.txt
+@@ -36,7 +36,7 @@ add_library(ofqf STATIC
+ set_target_properties (
+ ofqf
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(ofqf all)
+diff --git a/thirdparty/qzip/CMakeLists.txt b/thirdparty/qzip/CMakeLists.txt
+index 77b1997..417017e 100644
+--- a/thirdparty/qzip/CMakeLists.txt
++++ b/thirdparty/qzip/CMakeLists.txt
+@@ -29,7 +29,7 @@ add_library(qzip STATIC
+ set_target_properties (
+ qzip
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(qzip all)
+diff --git a/thirdparty/rtf2html/CMakeLists.txt b/thirdparty/rtf2html/CMakeLists.txt
+index 230339b..6c94a06 100644
+--- a/thirdparty/rtf2html/CMakeLists.txt
++++ b/thirdparty/rtf2html/CMakeLists.txt
+@@ -37,7 +37,7 @@ add_library (
+
+ set_target_properties( rtf2html
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(rtf2html all)
+diff --git a/thirdparty/singleapp/src/CMakeLists.txt b/thirdparty/singleapp/src/CMakeLists.txt
+index 2504b01..936fa3f 100644
+--- a/thirdparty/singleapp/src/CMakeLists.txt
++++ b/thirdparty/singleapp/src/CMakeLists.txt
+@@ -31,7 +31,7 @@ add_library (
+ set_target_properties (
+ qtsingleapp
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(qtsingleapp all)
+diff --git a/thirdparty/xmlstream/CMakeLists.txt b/thirdparty/xmlstream/CMakeLists.txt
+index 5991e09..7f1268e 100644
+--- a/thirdparty/xmlstream/CMakeLists.txt
++++ b/thirdparty/xmlstream/CMakeLists.txt
+@@ -29,7 +29,7 @@ add_library(xmlstream STATIC
+ set_target_properties (
+ xmlstream
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(xmlstream all)
+diff --git a/zerberus/CMakeLists.txt b/zerberus/CMakeLists.txt
+index c0db571..58d8ddf 100644
+--- a/zerberus/CMakeLists.txt
++++ b/zerberus/CMakeLists.txt
+@@ -31,7 +31,7 @@ add_library (zerberus STATIC
+ set_target_properties (
+ zerberus
+ PROPERTIES
+- COMPILE_FLAGS "${PCH_INCLUDE} -g -Wall -Wextra -Winvalid-pch"
++ COMPILE_FLAGS "${PCH_INCLUDE} -Wall -Wextra -Winvalid-pch"
+ )
+
+ xcode_pch(zerberus all)