summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pianobooster/pianobooster-0.6.4b.ebuild')
-rw-r--r--media-sound/pianobooster/pianobooster-0.6.4b.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/media-sound/pianobooster/pianobooster-0.6.4b.ebuild b/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
deleted file mode 100644
index ca211b2aa50a..000000000000
--- a/media-sound/pianobooster/pianobooster-0.6.4b.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-MY_P=${PN}-src-${PV}
-
-DESCRIPTION="A MIDI file player that teaches how to play the piano"
-HOMEPAGE="http://pianobooster.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="fluidsynth"
-
-DEPEND="fluidsynth? ( media-sound/fluidsynth )
- media-libs/alsa-lib
- virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtopengl:4"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-cmake.patch
- "${FILESDIR}"/${P}-gcc47.patch
- "${FILESDIR}"/${P}-underlinking.patch
-)
-DOCS=( ReleaseNote.txt ../README.txt )
-
-S=${WORKDIR}/${MY_P}/src
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_FLUIDSYNTH=$(usex fluidsynth)
- )
- cmake-utils_src_configure
-}