summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch')
-rw-r--r--media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch b/media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch
new file mode 100644
index 000000000000..44b7c3cb6443
--- /dev/null
+++ b/media-sound/qsampler/files/qsampler-0.9.1-cmake-no-git.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8304e80..666deb5 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -6,6 +6,7 @@ project(qsampler
+ LANGUAGES C CXX)
+
+ set (CONFIG_VERSION ${PROJECT_VERSION})
++#[[
+ execute_process (
+ COMMAND git describe --tags --dirty --abbrev=6
+ OUTPUT_VARIABLE GIT_DESCRIBE_OUTPUT
+@@ -27,6 +28,8 @@ if (GIT_DESCRIBE_RESULT EQUAL 0)
+ else ()
+ set (VERSION "${PROJECT_VERSION}")
+ endif ()
++]]
++set (VERSION "${PROJECT_VERSION}")
+
+ set (PACKAGE_NAME "Qsampler")
+ set (PACKAGE_VERSION "${VERSION}")