summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/streamripper/streamripper-1.64.6.ebuild')
-rw-r--r--media-sound/streamripper/streamripper-1.64.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/streamripper/streamripper-1.64.6.ebuild b/media-sound/streamripper/streamripper-1.64.6.ebuild
new file mode 100644
index 000000000000..88c6910bdb29
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.64.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="vorbis"
+
+RDEPEND="media-libs/libmad
+ media-libs/faad2
+ >=dev-libs/glib-2.16
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --without-included-libmad \
+ --without-included-argv \
+ $(use_with vorbis ogg)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES parse_rules.txt README THANKS
+}