summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/timemachine/timemachine-0.3.1.ebuild')
-rw-r--r--media-sound/timemachine/timemachine-0.3.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-sound/timemachine/timemachine-0.3.1.ebuild b/media-sound/timemachine/timemachine-0.3.1.ebuild
new file mode 100644
index 000000000000..360164c5e4a5
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed"
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="http://plugin.org.uk/timemachine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="lash"
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.80
+ x11-libs/gtk+:2
+ >=media-libs/libsndfile-1.0.5
+ lash? ( >=media-sound/lash-0.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog
+}