summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/blind/blind-1.1.ebuild')
-rw-r--r--media-video/blind/blind-1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-video/blind/blind-1.1.ebuild b/media-video/blind/blind-1.1.ebuild
new file mode 100644
index 000000000000..350b74acd248
--- /dev/null
+++ b/media-video/blind/blind-1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="a collection of command line video editing utilities"
+HOMEPAGE="https://tools.suckless.org/blind/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1-ldflags.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CC/d' \
+ -e 's|/usr/local|/usr|g' \
+ -e 's|^CFLAGS.*|CFLAGS += -std=c99 -pedantic -Wall -Wextra $(INCS) $(CPPFLAGS)|g' \
+ -e '/^LDFLAGS.*/ { s:-s::g; s:=:+=:g; }' \
+ -e 's|{|(|g;s|}|)|g' \
+ config.mk || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install MANPREFIX=/usr/share/man
+}