summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vcdimager/vcdimager-2.0.1.ebuild')
-rw-r--r--media-video/vcdimager/vcdimager-2.0.1.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/media-video/vcdimager/vcdimager-2.0.1.ebuild b/media-video/vcdimager/vcdimager-2.0.1.ebuild
index 618eb4d7ef3c..0eed4a6d6233 100644
--- a/media-video/vcdimager/vcdimager-2.0.1.ebuild
+++ b/media-video/vcdimager/vcdimager-2.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit multilib-minimal
+inherit autotools multilib-minimal
DESCRIPTION="GNU VCDimager"
HOMEPAGE="https://www.gnu.org/software/vcdimager/"
@@ -20,11 +20,13 @@ RDEPEND="
xml? ( dev-libs/libxml2:2 )
"
DEPEND="${RDEPEND}
- virtual/pkgconfig
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
"
DOCS=( AUTHORS BUGS ChangeLog FAQ HACKING NEWS README THANKS TODO )
+PATCHES=("${FILESDIR}/${P}-pkg-config.patch")
+
src_prepare() {
default
@@ -32,10 +34,12 @@ src_prepare() {
sed -i \
-e 's/check_PROGRAMS =/check_PROGRAMS +=/' \
-e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
- test/Makefile.in || die
+ test/Makefile.am || die
sed -i \
-e 's/noinst_PROGRAMS =/check_PROGRAMS =/' \
- example/Makefile.in || die
+ example/Makefile.am || die
+
+ eautoreconf
}
multilib_src_configure() {