summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/vidcutter/vidcutter-6.0.0-r1.ebuild')
-rw-r--r--media-video/vidcutter/vidcutter-6.0.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-video/vidcutter/vidcutter-6.0.0-r1.ebuild b/media-video/vidcutter/vidcutter-6.0.0-r1.ebuild
new file mode 100644
index 000000000000..b3beb94619d7
--- /dev/null
+++ b/media-video/vidcutter/vidcutter-6.0.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="FFmpeg-based simple video cutter & joiner with a modern PyQt5 GUI"
+HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter"
+
+if [[ ${PV} == 9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ozmartian/vidcutter"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ozmartian/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=media-video/mpv-0.25[libmpv]
+"
+RDEPEND="${DEPEND}
+ >=dev-python/PyQt5-5.7[dbus,multimedia,${PYTHON_USEDEP}]
+ media-video/ffmpeg[X,encode]
+ media-video/mediainfo"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/share/doc/${PN}" "${ED}/usr/share/doc/${P}"
+}