summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/vidify/files/vidify-2.2.6-python310.patch16
-rw-r--r--media-video/vidify/vidify-2.2.6-r2.ebuild (renamed from media-video/vidify/vidify-2.2.6-r1.ebuild)5
2 files changed, 20 insertions, 1 deletions
diff --git a/media-video/vidify/files/vidify-2.2.6-python310.patch b/media-video/vidify/files/vidify-2.2.6-python310.patch
new file mode 100644
index 000000000000..4b78ea559333
--- /dev/null
+++ b/media-video/vidify/files/vidify-2.2.6-python310.patch
@@ -0,0 +1,16 @@
+diff --git a/vidify/player/vlc.py b/vidify/player/vlc.py
+index a7c9ec0..cb50f89 100644
+--- a/vidify/player/vlc.py
++++ b/vidify/player/vlc.py
+@@ -75,9 +75,9 @@ class VLCPlayer(PlayerBase):
+ def start_video(self, media: str, is_playing: bool = True) -> None:
+ logging.info("Starting new video")
+ if CURRENT_PLATFORM in (Platform.LINUX, Platform.BSD):
+- self._player.set_xwindow(self.winId())
++ self._player.set_xwindow(int(self.winId()))
+ elif CURRENT_PLATFORM == Platform.WINDOWS:
+- self._player.set_hwnd(self.winId())
++ self._player.set_hwnd(int(self.winId()))
+ elif CURRENT_PLATFORM == Platform.MACOS:
+ self._player.set_nsobject(int(self.winId()))
+
diff --git a/media-video/vidify/vidify-2.2.6-r1.ebuild b/media-video/vidify/vidify-2.2.6-r2.ebuild
index ae5d74063584..fe640744473d 100644
--- a/media-video/vidify/vidify-2.2.6-r1.ebuild
+++ b/media-video/vidify/vidify-2.2.6-r2.ebuild
@@ -32,7 +32,10 @@ RDEPEND="
"
# use yt-dlp instead of youtube-dl, otherwise download is too slow for playback
-PATCHES=( "${FILESDIR}/${P}-yt-dlp.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-yt-dlp.patch"
+ "${FILESDIR}/${P}-python310.patch"
+)
distutils_enable_tests unittest