summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mplayer/mplayer-1.3.0-r5.ebuild19
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild19
2 files changed, 12 insertions, 26 deletions
diff --git a/media-video/mplayer/mplayer-1.3.0-r5.ebuild b/media-video/mplayer/mplayer-1.3.0-r5.ebuild
index b7f1b8d3f164..b3c344f98b88 100644
--- a/media-video/mplayer/mplayer-1.3.0-r5.ebuild
+++ b/media-video/mplayer/mplayer-1.3.0-r5.ebuild
@@ -19,7 +19,7 @@ radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_
tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
vorbis +X x264 xinerama +xscreensaver +xv xvid yuv4mpeg zoran"
-VIDEO_CARDS="mga tdfx"
+VIDEO_CARDS="mga"
for x in ${VIDEO_CARDS}; do
IUSE+=" video_cards_${x}"
done
@@ -425,18 +425,11 @@ src_configure() {
myconf+=" --disable-mga --disable-xmga"
fi
- if use video_cards_tdfx; then
- myconf+="
- $(use_enable video_cards_tdfx tdfxvid)
- $(use_enable fbcon tdfxfb)
- "
- else
- myconf+="
- --disable-3dfx
- --disable-tdfxvid
- --disable-tdfxfb
- "
- fi
+ myconf+="
+ --disable-3dfx
+ --disable-tdfxvid
+ --disable-tdfxfb
+ "
# sun card, disable by default, see bug #258729
myconf+=" --disable-xvr100"
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 8d1ad1c2a300..62db816aa75e 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -19,7 +19,7 @@ radio rar rtc rtmp samba selinux +shm sdl speex cpu_flags_x86_sse cpu_flags_x86_
tga theora tremor +truetype toolame twolame +unicode v4l vcd vdpau vidix
vorbis +X x264 xinerama +xscreensaver +xv xvid yuv4mpeg zoran"
-VIDEO_CARDS="mga tdfx"
+VIDEO_CARDS="mga"
for x in ${VIDEO_CARDS}; do
IUSE+=" video_cards_${x}"
done
@@ -419,18 +419,11 @@ src_configure() {
myconf+=" --disable-mga --disable-xmga"
fi
- if use video_cards_tdfx; then
- myconf+="
- $(use_enable video_cards_tdfx tdfxvid)
- $(use_enable fbcon tdfxfb)
- "
- else
- myconf+="
- --disable-3dfx
- --disable-tdfxvid
- --disable-tdfxfb
- "
- fi
+ myconf+="
+ --disable-3dfx
+ --disable-tdfxvid
+ --disable-tdfxfb
+ "
# sun card, disable by default, see bug #258729
myconf+=" --disable-xvr100"