summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest3
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild47
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild (renamed from net-analyzer/cacti-spine/cacti-spine-1.2.16.ebuild)28
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-9999.ebuild (renamed from net-analyzer/cacti-spine/cacti-spine-99999.ebuild)16
4 files changed, 20 insertions, 74 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 9d350c261ff8..8686e9b07669 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1 @@
-DIST cacti-spine-1.2.16.tar.gz 108252 BLAKE2B ba0349cff7f4e82a5dc1d90c216cf7a4e0f939e28ab20d008b1725c948a85a00e2594f8997c8bbd69c305e3e58d944858c8439210956f45220b67229bc6df13d SHA512 0259084d70f9c8d20a8b19daf61e525228f99fba3eac4e2e5c9865114a5f1231b18389ca955fc4644c71c6c48cc45dda9b17e969a02c80552b84f98ad8945951
-DIST cacti-spine-1.2.17.tar.gz 110371 BLAKE2B 1f9605d34fcff0e4e7921ccbb5a22eeb9e2f2e2f22cf56189790dcdec798db5bff681df11cd82006254cc270174248c07ce3d94dca8d3367add6b220f1599adf SHA512 4c616af041d2f08e18fd274409c98d3efce84b7cca2d6e23db3d6c2a0d4c9a77a2c52c0ef8e0ed0c6ad409f28b56fdf3160e27654522d8aeb1b88e3cb4128d4a
+DIST cacti-spine-1.2.20.tar.gz 115258 BLAKE2B 78a9ed8a9e7e69e98bfa9971134dd6f34f540a93b0b1a2aababb66781f3c9787712d57d86b81d7f409487c4cc4447d4f84bd7292890b7eb70ec4137d97248793 SHA512 d7e129f7b42542d7ecc78d55cebc6d9ce481834342d3f3da1fce5538d8e42bc194a825795053d5e3a065b54574e2a3b9413725f1bc0562e55f1db213f9a94d0c
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild
deleted file mode 100644
index 6c9200ecdceb..000000000000
--- a/net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-MY_P=${PN}-${PV/_p/-}
-
-DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
-HOMEPAGE="https://cacti.net/spine_info.php"
-SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 sparc x86"
-
-BDEPEND="sys-apps/help2man"
-DEPEND="
- dev-libs/openssl:0=
- net-analyzer/net-snmp:=
- dev-db/mysql-connector-c:0=
-"
-RDEPEND="
- ${DEPEND}
- >net-analyzer/cacti-0.8.8
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_install() {
- dosbin spine
-
- insinto /etc/
- insopts -m0640 -o root
- newins spine.conf{.dist,}
-
- doman spine.1
- dodoc CHANGELOG
-}
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.16.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild
index 6c9200ecdceb..8cadbd1d2cb0 100644
--- a/net-analyzer/cacti-spine/cacti-spine-1.2.16.ebuild
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.20.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
@@ -15,26 +15,24 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ~hppa ~ppc ~ppc64 sparc x86"
+DEPEND="dev-db/mysql-connector-c:=
+ dev-libs/openssl:=
+ net-analyzer/net-snmp:="
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.8"
BDEPEND="sys-apps/help2man"
-DEPEND="
- dev-libs/openssl:0=
- net-analyzer/net-snmp:=
- dev-db/mysql-connector-c:0=
-"
-RDEPEND="
- ${DEPEND}
- >net-analyzer/cacti-0.8.8
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
-)
src_prepare() {
default
+
eautoreconf
}
+src_configure() {
+ # Drop CONFIG_SHELL after 1.2.x (fix is on develop branch)
+ CONFIG_SHELL="${BROOT}"/bin/bash econf
+}
+
src_install() {
dosbin spine
diff --git a/net-analyzer/cacti-spine/cacti-spine-99999.ebuild b/net-analyzer/cacti-spine/cacti-spine-9999.ebuild
index d929a4df7fcb..cfc27aa3907f 100644
--- a/net-analyzer/cacti-spine/cacti-spine-99999.ebuild
+++ b/net-analyzer/cacti-spine/cacti-spine-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools git-r3
@@ -13,18 +13,13 @@ EGIT_REPO_URI="https://github.com/Cacti/spine"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS=""
BDEPEND="sys-apps/help2man"
-DEPEND="
- dev-libs/openssl:0=
+DEPEND="dev-libs/openssl:=
net-analyzer/net-snmp:=
- dev-db/mysql-connector-c:0=
-"
-RDEPEND="
- ${DEPEND}
- >net-analyzer/cacti-0.8.8
-"
+ dev-db/mysql-connector-c:0="
+RDEPEND="${DEPEND}
+ >net-analyzer/cacti-0.8.8"
PATCHES=(
"${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
@@ -32,6 +27,7 @@ PATCHES=(
src_prepare() {
default
+
eautoreconf
}