summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/cryptcat/files')
-rw-r--r--net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch43
-rw-r--r--net-analyzer/cryptcat/files/cryptcat-1.2.1-misc.patch48
2 files changed, 91 insertions, 0 deletions
diff --git a/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch b/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
new file mode 100644
index 000000000000..17ec33489c89
--- /dev/null
+++ b/net-analyzer/cryptcat/files/cryptcat-1.2.1-build.patch
@@ -0,0 +1,43 @@
+--- a/unix/Makefile
++++ b/unix/Makefile
+@@ -10,16 +10,14 @@
+ # debugging
+ # DFLAGS = -DTEST -DDEBUG
+ DFLAGS = -DGAPING_SECURITY_HOLE
+-CFLAGS = -O
++CFLAGS ?= -O
+ XFLAGS = # xtra cflags, set by systype targets
+ XLIBS = # xtra libs if necessary?
+ # -Bstatic for sunos, -static for gcc, etc. You want this, trust me.
+ STATIC =
+-CC = cc $(CFLAGS)
+-LD = $(CC) -s # linker; defaults to stripped executables
+ o = o # object extension
+
+-ALL = cryptcat
++all: cryptcat
+
+ ### BOGON-CATCHERS
+
+@@ -28,8 +26,8 @@
+
+ ### HARD TARGETS
+
+-cryptcat: netcat.c farm9crypt.o twofish2.o
+- $(LD) $(DFLAGS) $(XFLAGS) $(STATIC) -o cryptcat netcat.c farm9crypt.o twofish2.o $(XLIBS)
++cryptcat: netcat.o farm9crypt.o twofish2.o
++ $(CXX) $(CXXFLAGS) $(LDFLAGS) -o $@ $^
+
+ nc-dos:
+ @echo "DOS?! Maybe someday, but not now"
+@@ -115,10 +112,8 @@
+ make -e $(ALL) $(MFLAGS) XFLAGS='-DNEXT' STATIC=-Bstatic
+
+ farm9crypt.o: farm9crypt.cc farm9crypt.h
+- ${CC} -c farm9crypt.cc
+
+ twofish2.o: twofish2.cc twofish2.h
+- ${CC} -c twofish2.cc
+
+ # start with this for a new architecture, and see what breaks.
+ generic:
diff --git a/net-analyzer/cryptcat/files/cryptcat-1.2.1-misc.patch b/net-analyzer/cryptcat/files/cryptcat-1.2.1-misc.patch
new file mode 100644
index 000000000000..8a2f9394b4a6
--- /dev/null
+++ b/net-analyzer/cryptcat/files/cryptcat-1.2.1-misc.patch
@@ -0,0 +1,48 @@
+--- a/netcat.c
++++ b/netcat.c
+@@ -39,7 +39,7 @@
+ /* conditional includes -- a very messy section which you may have to dink
+ for your own architecture [and please send diffs...]: */
+ /* #undef _POSIX_SOURCE /* might need this for something? */
+-#define HAVE_BIND /* ASSUMPTION -- seems to work everywhere! */
++#undef HAVE_BIND /* ASSUMPTION -- seems to work everywhere! */
+ #define HAVE_HELP /* undefine if you dont want the help text */
+ /* #define ANAL /* if you want case-sensitive DNS matching */
+
+@@ -56,7 +56,7 @@
+ #ifdef FD_SETSIZE /* should be in types.h, butcha never know. */
+ #undef FD_SETSIZE /* if we ever need more than 16 active */
+ #endif /* fd's, something is horribly wrong! */
+-#define FD_SETSIZE 16 /* <-- this'll give us a long anyways, wtf */
++#define FD_SETSIZE 1024 /* <-- this'll give us a long anyways, wtf */
+ #include <sys/types.h> /* *now* do it. Sigh, this is broken */
+
+ #ifdef HAVE_RANDOM /* aficionados of ?rand48() should realize */
+@@ -81,8 +81,10 @@
+ #include <errno.h>
+ #include <signal.h>
+ #include <fcntl.h> /* O_WRONLY et al */
++#include <unistd.h> /* alarm() close() sleep() */
++#include <time.h> /* time() */
+
+-#ifdef LINUX
++#ifdef __linux__
+ #include <resolv.h>
+ #endif
+
+--- a/generic.h
++++ b/generic.h
+@@ -274,7 +274,7 @@
+
+ /* linux, which is trying as desperately as the gnu folks can to be
+ POSIXLY_CORRECT. I think I'm gonna hurl... */
+-#ifdef LINUX
++#ifdef __linux__
+ #undef UTMPX
+ #undef HAVE_SYSINFO
+ #undef HAVE_SELECT_H
+@@ -373,3 +373,4 @@
+ /* ================ */
+ #endif /* GENERIC_H */
+
++#define arm arm_timer