summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/hunt/hunt-1.5-r2.ebuild')
-rw-r--r--net-analyzer/hunt/hunt-1.5-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-analyzer/hunt/hunt-1.5-r2.ebuild b/net-analyzer/hunt/hunt-1.5-r2.ebuild
new file mode 100644
index 000000000000..f9ce55c25250
--- /dev/null
+++ b/net-analyzer/hunt/hunt-1.5-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="tool for checking well known weaknesses in the TCP/IP protocol"
+HOMEPAGE="http://lin.fsid.cvut.cz/~kra/index.html"
+SRC_URI="http://lin.fsid.cvut.cz/~kra/hunt/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-exit.patch \
+ "${FILESDIR}"/${P}-flags.patch \
+ "${FILESDIR}"/${P}-log2.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ dobin hunt
+ doman man/hunt.1
+ dodoc CHANGES README* TODO tpsetup/transproxy
+}