summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/icinga2')
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.4.4-r1.ebuild162
-rw-r--r--net-analyzer/icinga2/icinga2-2.5.4.ebuild166
3 files changed, 0 insertions, 329 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index 047e607111b7..1e94b1b205f4 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,2 +1 @@
-DIST icinga2-2.4.4.tar.gz 1361983 SHA256 ce19ed52c447929f5f9dae11b75d080b76b7aa680ee930c59db4202a2218d6b5 SHA512 117c4ce3c6fe34bf41ae6c51d1ba35d4eb2e96e8e1f856f01e416752a40c5cb16d7d0443b9bda05c774369b827b757416279635f946bc589ec9cb9d65306b3cf WHIRLPOOL 032a080835640f19ca56918af8d451fe5f95dd483fd76f7bd5ff719d8676e2d245aad1e16eacc2f006d2b3c13f7b1f79b075e2216e21f330e3690e6bd397c050
DIST icinga2-2.5.4.tar.gz 2493864 SHA256 f22ca17cd9951598ab6a1bc27c1ef82b9f1bb49795f69066ccd4d499faa240fc SHA512 0fca05d3eb6722cedecaba1da78ebb7268482257f28e37831f6356c618cbd059304a9e27e1f786799f253940e3dcf8ffa7399060f3e0e15765594796657b3be4 WHIRLPOOL a2a4af45a15cc4ed197151cc4e3355fa5f28ba227269990704f2cce47fe1990fb38932aa0bfefa8034492b379e04213d1eb514437e13aca3fe751592aff99afd
diff --git a/net-analyzer/icinga2/icinga2-2.4.4-r1.ebuild b/net-analyzer/icinga2/icinga2-2.4.4-r1.ebuild
deleted file mode 100644
index fcb077510f3e..000000000000
--- a/net-analyzer/icinga2/icinga2-2.4.4-r1.ebuild
+++ /dev/null
@@ -1,162 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils depend.apache eutils systemd toolchain-funcs user
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm x86"
-IUSE="+mysql postgres classicui console lto mail minimal nano-syntax +plugins studio +vim-syntax"
-
-CDEPEND="
- dev-libs/openssl:0
- >=dev-libs/boost-1.41
- console? ( dev-libs/libedit )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:= )"
-
-DEPEND="
- ${CDEPEND}
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-
-RDEPEND="
- ${CDEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )
- studio? ( x11-libs/wxGTK:2.9 )"
-
-REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_configure() {
- sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=FALSE
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_USER=icinga
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
- -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
- )
- fi
- # LTO
- if use lto; then
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=OFF
- )
- fi
- # STUDIO
- if use studio; then
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=OFF
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd "${BUILDDIR}" || die
-
- emake DESTDIR="${D}" install
-
- einstalldocs
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/var/run" || die "failed to remove /var/run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners icinga:icinga /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
- elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
-}
diff --git a/net-analyzer/icinga2/icinga2-2.5.4.ebuild b/net-analyzer/icinga2/icinga2-2.5.4.ebuild
deleted file mode 100644
index 7789098be0e2..000000000000
--- a/net-analyzer/icinga2/icinga2-2.5.4.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit cmake-utils depend.apache eutils systemd toolchain-funcs user
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax"
-
-CDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- >=dev-libs/boost-1.41
- console? ( dev-libs/libedit )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:= )"
-
-DEPEND="
- ${CDEPEND}
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-
-RDEPEND="
- ${CDEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )
- studio? ( x11-libs/wxGTK:2.9 )"
-
-REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_configure() {
- sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=FALSE
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_USER=icinga
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- -DLOGROTATE_HAS_SU=ON
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
- -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
- )
- fi
- # LTO
- if use lto; then
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=OFF
- )
- fi
- # STUDIO
- if use studio; then
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=OFF
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd "${BUILDDIR}" || die
-
- emake DESTDIR="${D}" install
-
- einstalldocs
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/var/run" || die "failed to remove /var/run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners icinga:icinga /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} && ${REPLACING_VERSIONS} != ${PV} ]]; then
- elog "DB IDO schema upgrade may be required required.
- http://docs.icinga.org/icinga2/snapshot/doc/module/icinga2/chapter/upgrading-icinga-2"
- fi
-}