summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/icinga2')
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.5.4-r1.ebuild176
-rw-r--r--net-analyzer/icinga2/icinga2-2.7.0.ebuild2
3 files changed, 1 insertions, 178 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index 40628adac7de..e51208d8bbc6 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,4 +1,3 @@
-DIST icinga2-2.5.4.tar.gz 2493864 SHA256 f22ca17cd9951598ab6a1bc27c1ef82b9f1bb49795f69066ccd4d499faa240fc SHA512 0fca05d3eb6722cedecaba1da78ebb7268482257f28e37831f6356c618cbd059304a9e27e1f786799f253940e3dcf8ffa7399060f3e0e15765594796657b3be4 WHIRLPOOL a2a4af45a15cc4ed197151cc4e3355fa5f28ba227269990704f2cce47fe1990fb38932aa0bfefa8034492b379e04213d1eb514437e13aca3fe751592aff99afd
DIST icinga2-2.6.2.tar.gz 2357220 SHA256 c2058c0e6c39860c52a57b8ce79224729f34b48bc96fb7b1ae2b742909e9b71b SHA512 733370fb120b79bbe3bdbf3d4b640083ff26d2a872c545f4efcd23be3462435f75e0b43b269b770296cb6de4a0529f2369fb766e06444d3fdb56f04db6a3dd03 WHIRLPOOL 0d28a429e5068a490a85ebced3b102780327519968f0cdc7eb3d939d91b6199ee285e0ca524d8596681b2c82832d8fc1909974f5f7e2ecbf0b7fe2ffc908327d
DIST icinga2-2.6.3.tar.gz 2360602 SHA256 83d44871a70d1b368b1af717873ff9b1b185344d23fc79b83118e47a85da6d90 SHA512 c6512411689951611b19a5e80bf360b4cf5ddbf95dcb47cb393f90798e36c052c68b79a5a33a72cd6205ab58d4bb3ac44ec4cd82f9d1d17dc3c0e550723272b3 WHIRLPOOL 9e2c116be306cce35d780387cd2487a7a33b5819166308b83bb26d17cb856094f67d80ea110370b13e7fa19d84463b73da1a65fbf0de60663f2ad53e25c19108
DIST icinga2-2.7.0.tar.gz 2435398 SHA256 8f06d23e5d922ba7a74f92dbb9af792be063d06d3aea9011aba39370935c6980 SHA512 470dd4ffa4ef608a018ede5c25b41f16213bf18c679eed8aaeed155fe6adc74a70abcc2e8be42ca20bf60f9b4b620c971ebbc96d608de2a90e480d72b93111bb WHIRLPOOL c926086c296affaafc7d55471ea5c1414b2d2cb8545657215a53bb9744c3147c32f8398317ad670e0d12fb95c83b54f0712f061e5e93bab868c4f04d833c3b47
diff --git a/net-analyzer/icinga2/icinga2-2.5.4-r1.ebuild b/net-analyzer/icinga2/icinga2-2.5.4-r1.ebuild
deleted file mode 100644
index 12bfa48676c0..000000000000
--- a/net-analyzer/icinga2/icinga2-2.5.4-r1.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-if [[ ${PV} != 9999 ]]; then
- inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
- SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 x86"
-else
- inherit cmake-utils depend.apache eutils git-2 systemd toolchain-funcs user wxwidgets
- EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"
- EGIT_BRANCH="master"
- KEYWORDS=""
-fi
-
-DESCRIPTION="Distributed, general purpose, network monitoring engine"
-HOMEPAGE="http://icinga.org/icinga2"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="+mysql postgres classicui console libressl lto mail minimal nano-syntax +plugins studio +vim-syntax"
-WX_GTK_VER="3.0"
-
-CDEPEND="
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- >=dev-libs/boost-1.41
- console? ( dev-libs/libedit )
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql:= )"
-
-DEPEND="
- ${CDEPEND}
- sys-devel/bison
- >=sys-devel/flex-2.5.35"
-
-RDEPEND="
- ${CDEPEND}
- plugins? ( || (
- net-analyzer/monitoring-plugins
- net-analyzer/nagios-plugins
- ) )
- mail? ( virtual/mailx )
- classicui? ( net-analyzer/icinga[web] )
- studio? ( x11-libs/wxGTK:3.0 )"
-
-REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
-
-want_apache2
-
-pkg_setup() {
- depend.apache_pkg_setup
- if use studio ; then
- setup-wxwidgets
- fi
- enewgroup icinga
- enewgroup icingacmd
- enewgroup nagios # for plugins
- enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
-}
-
-src_configure() {
- sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
- local mycmakeargs=(
- -DICINGA2_UNITY_BUILD=FALSE
- -DCMAKE_VERBOSE_MAKEFILE=ON
- -DCMAKE_BUILD_TYPE=None
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_INSTALL_SYSCONFDIR=/etc
- -DCMAKE_INSTALL_LOCALSTATEDIR=/var
- -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
- -DICINGA2_USER=icinga
- -DICINGA2_GROUP=icingacmd
- -DICINGA2_COMMAND_USER=icinga
- -DICINGA2_COMMAND_GROUP=icingacmd
- -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
- -DLOGROTATE_HAS_SU=ON
- )
- # default to off if minimal, allow the flags to be set otherwise
- if use minimal; then
- mycmakeargs+=(
- -DICINGA2_WITH_MYSQL=OFF
- -DICINGA2_WITH_PGSQL=OFF
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
- -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
- )
- fi
- # LTO
- if use lto; then
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_LTO_BUILD=OFF
- )
- fi
- # STUDIO
- if use studio; then
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=ON
- )
- else
- mycmakeargs+=(
- -DICINGA2_WITH_STUDIO=OFF
- )
- fi
-
- cmake-utils_src_configure
-}
-
-src_install() {
- BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
- cd "${BUILDDIR}" || die
-
- emake DESTDIR="${D}" install
-
- einstalldocs
-
- newinitd "${FILESDIR}"/icinga2.initd icinga2
- newconfd "${FILESDIR}"/icinga2.confd icinga2
-
- if use mysql ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
- elif use postgres ; then
- docinto schema
- newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
- docinto schema/upgrade
- dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
- fi
-
- keepdir /etc/icinga2
- keepdir /var/lib/icinga2/api/zones
- keepdir /var/lib/icinga2/api/repository
- keepdir /var/lib/icinga2/api/log
- keepdir /var/spool/icinga2/perfdata
-
- rm -r "${D}/var/run" || die "failed to remove /var/run"
- rm -r "${D}/var/cache" || die "failed to remove /var/cache"
-
- fowners icinga:icinga /etc/icinga2
- fowners icinga:icinga /var/lib/icinga2
- fowners icinga:icinga /var/spool/icinga2
- fowners -R icinga:icingacmd /var/lib/icinga2/api
- fowners icinga:icinga /var/spool/icinga2/perfdata
- fowners icinga:icingacmd /var/log/icinga2
-
- fperms ug+rwX,o-rwx /etc/icinga2
- fperms ug+rwX,o-rwx /var/lib/icinga2
- fperms ug+rwX,o-rwx /var/spool/icinga2
- fperms ug+rwX,o-rwx /var/log/icinga2
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
- doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
- fi
-
- if use nano-syntax; then
- insinto /usr/share/nano
- doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
- fi
-}
-
-pkg_postinst() {
- if [[ ${PV} != 9999 && -n ${REPLACING_VERSIONS} && ${REPLACING_VERSIONS} != ${PV} ]]; then
- elog "DB IDO schema upgrade may be required required.
- http://docs.icinga.org/icinga2/snapshot/doc/module/icinga2/chapter/upgrading-icinga-2"
- fi
-}
diff --git a/net-analyzer/icinga2/icinga2-2.7.0.ebuild b/net-analyzer/icinga2/icinga2-2.7.0.ebuild
index 91fbbba61158..35df65d8c19c 100644
--- a/net-analyzer/icinga2/icinga2-2.7.0.ebuild
+++ b/net-analyzer/icinga2/icinga2-2.7.0.ebuild
@@ -5,7 +5,7 @@ EAPI=6
if [[ ${PV} != 9999 ]]; then
inherit cmake-utils depend.apache eutils systemd toolchain-funcs user wxwidgets
SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
else
inherit cmake-utils depend.apache eutils git-2 systemd toolchain-funcs user wxwidgets
EGIT_REPO_URI="https://github.com/Icinga/icinga2.git"