summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/masscan/masscan-1.0.4.ebuild')
-rw-r--r--net-analyzer/masscan/masscan-1.0.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/masscan/masscan-1.0.4.ebuild b/net-analyzer/masscan/masscan-1.0.4.ebuild
new file mode 100644
index 000000000000..4afaf4c90042
--- /dev/null
+++ b/net-analyzer/masscan/masscan-1.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Mass IP port scanner"
+HOMEPAGE="https://github.com/robertdavidgraham/masscan"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="AGPL-3"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ default
+
+ sed -i \
+ -e '/$(CC)/s!$(CFLAGS)!$(LDFLAGS) $(CFLAGS)!g' \
+ -e '/^GITVER :=/s!= .(.*!=!g' \
+ -e '/^SYS/s|gcc|$(CC)|g' \
+ -e '/$(CC)/s!-DGIT=\"$(GITVER)\"!!g' \
+ -e '/^CFLAGS =/{s,=,+=,;s,-g -ggdb,,;s,-O3,,;}' \
+ Makefile || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin bin/masscan
+
+ insinto /etc/masscan
+ doins data/exclude.conf
+ doins "${FILESDIR}"/masscan.conf
+
+ mv doc/bot.{hml,html} || die
+ dodoc doc/bot.html *.md
+
+ doman doc/masscan.8
+}