summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nagios-check_pidfile/nagios-check_pidfile-1.ebuild')
-rw-r--r--net-analyzer/nagios-check_pidfile/nagios-check_pidfile-1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/nagios-check_pidfile/nagios-check_pidfile-1.ebuild b/net-analyzer/nagios-check_pidfile/nagios-check_pidfile-1.ebuild
new file mode 100644
index 000000000000..894a2e33825b
--- /dev/null
+++ b/net-analyzer/nagios-check_pidfile/nagios-check_pidfile-1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="A nagios plugin for checking daemons via pidfiles"
+HOMEPAGE="https://github.com/hollow/check_pidfile"
+SRC_URI="https://github.com/hollow/check_pidfile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=net-analyzer/nagios-plugins-1.4.13-r1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/check_pidfile-${PV}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}