summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/nmap/nmap-9999.ebuild')
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild23
1 files changed, 7 insertions, 16 deletions
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index 053d71e84662..3fa4e3e598d7 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -2,8 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-MY_P=${P/_beta/BETA}
-inherit autotools desktop flag-o-matic git-r3 toolchain-funcs
+inherit autotools flag-o-matic git-r3 toolchain-funcs
DESCRIPTION="Network exploration tool and security / port scanner"
HOMEPAGE="https://nmap.org/"
@@ -11,7 +10,7 @@ HOMEPAGE="https://nmap.org/"
EGIT_REPO_URI="https://github.com/nmap/nmap"
SRC_URI="https://dev.gentoo.org/~jer/nmap-logo-64.png"
-LICENSE="GPL-2"
+LICENSE="NPSL"
SLOT="0"
IUSE="ipv6 libressl libssh2 ncat nping +nse ssl system-lua"
REQUIRED_USE="system-lua? ( nse )"
@@ -42,10 +41,9 @@ PATCHES=(
"${FILESDIR}"/${PN}-7.25-libpcre.patch
"${FILESDIR}"/${PN}-7.31-libnl.patch
"${FILESDIR}"/${PN}-7.80-ac-config-subdirs.patch
+ "${FILESDIR}"/${PN}-7.91-no-FORTIFY_SOURCE.patch
"${FILESDIR}"/${PN}-9999-netutil-else.patch
- "${FILESDIR}"/${PN}-9999-no-FORTIFY_SOURCE.patch
)
-S="${WORKDIR}/${MY_P}"
src_prepare() {
rm -r liblinear/ libpcap/ libpcre/ libssh2/ libz/ || die
@@ -57,11 +55,6 @@ src_prepare() {
sed -i \
-e '/^ALL_LINGUAS =/{s|$| id|g;s|jp|ja|g}' \
Makefile.in || die
- # Fix desktop files wrt bug #432714
- sed -i \
- -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
- zenmap/install_scripts/unix/zenmap-root.desktop \
- zenmap/install_scripts/unix/zenmap.desktop || die
cp libdnet-stripped/include/config.h.in{,.nmap-orig} || die
@@ -80,18 +73,16 @@ src_configure() {
$(use_enable ipv6) \
$(use_with libssh2) \
$(use_with ncat) \
- --without-ndiff \
$(use_with nping) \
$(use_with ssl openssl) \
- --without-zenmap \
$(usex libssh2 --with-zlib) \
- $(usex nse --with-zlib) \
$(usex nse --with-liblua=$(usex system-lua /usr included '' '') --without-liblua) \
+ $(usex nse --with-zlib) \
--cache-file="${S}"/config.cache \
--with-libdnet=included \
- --with-pcre=/usr
- # Commented out because configure does weird things
- # --with-liblinear=/usr \
+ --with-pcre=/usr \
+ --without-ndiff \
+ --without-zenmap
}
src_compile() {