summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild')
-rw-r--r--net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild b/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild
new file mode 100644
index 000000000000..0ab754a790be
--- /dev/null
+++ b/net-analyzer/openvas-cli/openvas-cli-1.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DL_ID=2141
+
+DESCRIPTION="A remote security scanner for Linux (OpenVAS-cli)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=" ~amd64 ~arm ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ >=net-analyzer/openvas-libraries-8.0.4
+ !net-analyzer/openvas-client"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_beta/+beta}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLOCALSTATEDIR="${EPREFIX}"/var
+ -DSYSCONFDIR="${EPREFIX}"/etc
+ )
+ cmake-utils_src_configure
+}