summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/python-gvm/python-gvm-21.11.0.ebuild')
-rw-r--r--net-analyzer/python-gvm/python-gvm-21.11.0.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
index b50a5c454cd0..72431694f204 100644
--- a/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
+++ b/net-analyzer/python-gvm/python-gvm-21.11.0.ebuild
@@ -4,24 +4,30 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+DISTUTILS_USE_PEP517=poetry
inherit distutils-r1
DESCRIPTION="Greenbone Vulnerability Management Python Library"
-HOMEPAGE="https://www.greenbone.net/en/ https://github.com/greenbone/python-gvm/"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/python-gvm/"
SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
SLOT="0"
LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="
dev-python/defusedxml[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/paramiko[${PYTHON_USEDEP}]"
-
+ dev-python/paramiko[${PYTHON_USEDEP}]
+"
DEPEND="${RDEPEND}"
distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # drop connection tests
+ rm -r tests/connections || die
+}