summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/sarg')
-rw-r--r--net-analyzer/sarg/files/sarg-2.3.11-Werror.patch25
-rw-r--r--net-analyzer/sarg/sarg-2.3.11-r2.ebuild44
2 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/sarg/files/sarg-2.3.11-Werror.patch b/net-analyzer/sarg/files/sarg-2.3.11-Werror.patch
new file mode 100644
index 000000000000..035578793934
--- /dev/null
+++ b/net-analyzer/sarg/files/sarg-2.3.11-Werror.patch
@@ -0,0 +1,25 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -46,18 +46,18 @@
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+-AC_MSG_CHECKING([for implicit-function-declaration error flag in $CC])
++AC_MSG_CHECKING([for implicit-function-declaration warning flag in $CC])
+ saved_CFLAGS="${CFLAGS}"
+-CFLAGS="${CFLAGS} -Werror=implicit-function-declaration"
++CFLAGS="${CFLAGS} -Wimplicit-function-declaration"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_implicit_function_declaration="yes"],[have_implicit_function_declaration="no"])
+ AC_MSG_RESULT($have_implicit_function_declaration)
+ if test "$have_implicit_function_declaration" = "no" ; then
+ CFLAGS="${saved_CFLAGS}"
+ fi
+
+-AC_MSG_CHECKING([for format error flag in $CC])
++AC_MSG_CHECKING([for format warning flag in $CC])
+ saved_CFLAGS="${CFLAGS}"
+-CFLAGS="${CFLAGS} -Werror=format"
++CFLAGS="${CFLAGS} -Wformat"
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([])],[have_error_format="yes"],[have_error_format="no"])
+ AC_MSG_RESULT($have_error_format)
+ if test "$have_error_format" = "no" ; then
diff --git a/net-analyzer/sarg/sarg-2.3.11-r2.ebuild b/net-analyzer/sarg/sarg-2.3.11-r2.ebuild
new file mode 100644
index 000000000000..c8afb3c48d45
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.3.11-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="https://sourceforge.net/projects/sarg/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+gd ldap pcre"
+
+DEPEND="
+ gd? ( media-libs/gd[png,truetype] )
+ ldap? ( net-nds/openldap )
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.10-config.patch
+ "${FILESDIR}"/${PN}-2.3.11-configure.patch
+ "${FILESDIR}"/${PN}-2.3.11-format.patch
+ "${FILESDIR}"/${PN}-2.3.11-Werror.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gd) \
+ $(use_with ldap) \
+ $(use_with pcre) \
+ --sysconfdir="${EPREFIX}/etc/sarg/"
+}