summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/traceproto')
-rw-r--r--net-analyzer/traceproto/Manifest1
-rw-r--r--net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch17
-rw-r--r--net-analyzer/traceproto/metadata.xml5
-rw-r--r--net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild42
4 files changed, 65 insertions, 0 deletions
diff --git a/net-analyzer/traceproto/Manifest b/net-analyzer/traceproto/Manifest
new file mode 100644
index 000000000000..24d5784a105c
--- /dev/null
+++ b/net-analyzer/traceproto/Manifest
@@ -0,0 +1 @@
+DIST traceproto-1.1.2beta1.tar.gz 192288 SHA256 96c1985793dd9913513669772efdf5736d4bc3af8cd2a852567be64ecd028900 SHA512 e7c99fd0ccc6a8e21901d538b9a05ff26807afdd749ab53e958722ad7fa54c27545c95e4bc390a6a06130e7a123f8fa4c7f794ca7b25180a4d3ca5044d1e7364 WHIRLPOOL 129f31cb97a12b6db08b6b4a717c44e884a9aadf876d374a04df091f03381d8bc458c3ba75940c395a8ab795d44da32db021eb78302b1a3ff678dadc596d0eee
diff --git a/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch b/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch
new file mode 100644
index 000000000000..383daaefd78b
--- /dev/null
+++ b/net-analyzer/traceproto/files/traceproto-1.1.2_beta1-tinfo.patch
@@ -0,0 +1,17 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,9 +182,11 @@
+ AC_CHECK_LIB(pcap, pcap_open_live, , AC_MSG_ERROR([ERROR - pcap check failed]))
+ AC_CHECK_LIB(net, libnet_init, , AC_MSG_ERROR([ERROR - libnet check failed]))
+ AC_CHECK_LIB(cap, cap_init, , AC_MSG_WARN([libcap check failed]))
+-AC_CHECK_LIB(ncurses, initscr, , AC_MSG_WARN([ncurses check failed]))
+-AC_CHECK_LIB(curses, initscr, , AC_MSG_WARN([curses check failed]))
+-AC_CHECK_LIB(termcap, tgetent)
++PKG_CHECK_MODULES(ncurses,ncurses,
++ LIBS="$LIBS $ncurses_LIBS"
++ AC_DEFINE([HAVE_NCURSES_H], 1, [We have ncurses headers])
++ AC_DEFINE([HAVE_LIBNCURSES], 1, [We have ncurses libraries]),
++ AC_MSG_ERROR([ncurses check failed]))
+ if test "x$dmalloc_test" = "xyes"; then
+ AC_CHECK_LIB(dmalloc, malloc, ,AC_MSG_RESULT([dmalloc unavailable]))
+ fi
diff --git a/net-analyzer/traceproto/metadata.xml b/net-analyzer/traceproto/metadata.xml
new file mode 100644
index 000000000000..78692635ad22
--- /dev/null
+++ b/net-analyzer/traceproto/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
new file mode 100644
index 000000000000..92df6c4bf1d3
--- /dev/null
+++ b/net-analyzer/traceproto/traceproto-1.1.2_beta1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+MY_PV=${PV/_/}
+
+DESCRIPTION="A traceroute-like utility that sends packets based on protocol"
+HOMEPAGE="http://traceproto.sourceforge.net/"
+SRC_URI="mirror://gentoo/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="debug"
+
+RDEPEND="
+ net-libs/libnet:1.1
+ net-libs/libpcap
+ sys-libs/ncurses
+ debug? ( dev-libs/dmalloc )
+"
+DEPEND="
+ ${RDEPEND}
+ app-doc/doxygen[dot]
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug dmalloc)
+}