summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wapiti/wapiti-3.0.3.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-3.0.3.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/net-analyzer/wapiti/wapiti-3.0.3.ebuild b/net-analyzer/wapiti/wapiti-3.0.3.ebuild
deleted file mode 100644
index 4537e62437ab..000000000000
--- a/net-analyzer/wapiti/wapiti-3.0.3.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE='xml'
-
-inherit distutils-r1
-
-MY_P=${PN}3-${PV}
-DESCRIPTION="Web-application vulnerability scanner"
-HOMEPAGE="http://wapiti.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="kerberos ntlm"
-
-RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
- dev-python/tld[${PYTHON_USEDEP}]
- dev-python/yaswfp[${PYTHON_USEDEP}]
- kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
- ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
-
-S=${WORKDIR}/${MY_P}
-
-python_prepare_all() {
- sed -e 's/"pytest-runner"//' -i setup.py || die
- distutils-r1_python_prepare_all
-}